sequences disappear with this command: qiime feature-table merge-seqs

Hi team,
Hope everyone is doing well.
I have one issue with merging my seqs inside qiime2.
I have four different independent runs genereted from dada2: seq1.qza, seq2.qza, seq3.qza, and seq4.qza which I wanted to merge as seq-merged.qza to be able to run Vsearch for taxonomic assignement at the same time. The problem is that the command used filtered out so many of my sequences. I am expecting to get 128,681 unique sequences but I got 104,247 instead. Here is the command used:

qiime feature-table merge-seqs
–i-data /mnt/beegfs/scratch/eh309/analysis-lane1and2/dada2lane2/repsequences-lane2-all.qza
–i-data /mnt/beegfs/scratch/eh309/chapter5/aoam3080819/rep-seqpaoam3.qza
–i-data /mnt/beegfs/scratch/eh309/chapter5/aoam4120819/dada2-4120819/rep-seqpaoam4.qza
–i-data /mnt/beegfs/scratch/eh309/analysis-lane1and2/dada2lane1/articlechapter4/representative_sequencelane1-all.qza
–o-merged-data rep-seqsMerged11Feb2021.qza

I tried to merge the sequences outside and I inported them as seq.fasta file then seq.qza but I got the error of index out of range, although the import of seq.fasta was successful.
Please any help will be highly appreciated.
Thanks a lot.

Hi @Hajar1,

Welcome to the :qiime2: forum!

It seems a bit perplexing that your numbers are different. Why are you expecting 128,681 sequences in your final merged representative sequences? Is there any possibility that your sequences could intersect and so you'd have fewer unique sequences?


1 Like

Thanks, Justine for your help,

I am expecting this number because I exported them before runing qiime feature-table merge-seqs. Then, I visualised them in other software (Geneious). They are unique already so I don’t see any reason why they disappear. I am expecting to get one bacteria which I know, is there for sure but it was also filtered out. I think there is an issue with the merge-seq command.
Many thanks for your help.

Hi @Hajar1,

I haven’t worked with Geneious before. Can you explain your workflow to get there more clearly, starting from importing your sequences to QIIME 2 and then going into Geneious?

Additionally, why do you think you’re losing this bacteria? How do you know this? What are you using to determine this.

If there is a bug with merge-seqs than its absolutely something that needs to be addressed, but it’s hard to determine that without a better idea of what’s been done and what the expectations are.


Hi Justine,
Thanks for your reply.

The bacteria in there I know that because the samples are my positives (mock communities) with known composition. when I run the samples separately without the command qiime feature-table merge-seqs I get them in the end in taxonomy.qza. However when I use merge-seq they disappear.
Geneious was used only to check and visualise seq.qza which I got from dada2.
so It is not included in the workflow.
The steps I used are: dada2 to filter (this step is fine).
then I took seq.qza for classification (this step is also fine).
The issue is with the command merge-seqs when I merge my seqs the bacteria which is supposed to be there disappear, but when I re-run without merge-seqs (each run seq1.qza, seq2.qza, seq3.qza and seq4.qza) I manage to get all my sequences back without any issue.
Hope this is clear now.
Your help is highly appreciated.

Hi @Hajar1,

What happens when you summarize your sequences in qiime2? When you merge the table, do you get 128,681 unique features or 104,247 unique features?


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.