Sequence Quality Control: Deblur Plugin Error

Hello Qiime2 Forum,

I seem to be running into some difficulty when doing sequence quality control using the deblur plugin for my demultiplexed paired-end sequences.

Here is the demultiplexed visualization file to refer to if needed: Paired-end-demux-sequences.qzv (290.7 KB)

Firstly, as referenced by the “Moving Pictures” tutorial, I did the initial quality filtering process based on quality scores which was successful. The command that I did is below:

  qiime quality-filter q-score \
> --i-demux Paired-end-demux-sequences.qza \
> --o-filtered-sequences Paired-demux-filtered.qza \
> --o-filter-stats Paired-demux-filter-stats.qza

https://drive.google.com/file/d/1eZgL2W9o9-JVRGkw81B2N8yV8kTd0R85/view?usp=sharing

Paired-demux-filter-stats.qza (10.7 KB)

From there, I went forward in the Deblur workflow with qiime deblur denoise-16S method. The command I inputted into the terminal is as follows:

qiime deblur denoise-16S --i-demultiplexed-seqs Paired-demux-filtered.qza --p-trim-length 300 --o-representative-sequences Paired-rep-seqs-deblur.qza --o-table Paired-table-deblur.qza --p-sample-stats --o-stats Paired-deblur-stats.qza

Each time that I put this command, even with different --p-trim-length values, I would end up with the following error:

Plugin error from deblur:

  Command '['deblur', 'workflow', '--seqs-fp', '/tmp/qiime2-archive-9xp_xuqn/88595039-92d4-42f5-90f9-e04d4add2012/data', '--output-dir', '/tmp/tmp8n29ubx7', '--mean-error', '0.005', '--indel-prob', '0.01', '--indel-max', '3', '--trim-length', '300', '--left-trim-length', '0', '--min-reads', '10', '--min-size', '2', '--jobs-to-start', '1', '-w', '--keep-tmp-files']' returned non-zero exit status 1.

Debug info has been saved to /tmp/qiime2-q2cli-err-owfipnwf.log

Here is the deblur.log for reference. I had to share 2 files on this topic through Google Drive since they were too large.

https://drive.google.com/file/d/1FAosTaC7VxK-pHYsxiXTLUmQicpeQE1d/view?usp=sharing

I tried to use the DADA2 plugin instead but I would also end up with the same error. I looked through past forum posts for guidance but still no luck… Any ideas on what I should do next?

Thank you,
Hasti

Hi @Hasti_A,

You may want to look at the “Atacama soil microbiome” tutorial for paired end sequences with DADA2 or Alternative methods of read joining for Deblur.

Best,
Justine

1 Like

The brilliant and talented @Mehrbod_Estaki has also pointed that for you and future users that the error may be a result of the trim length. You may wish to look at the post-quality. filter trim length to chose one which works better for your data.

Best,
Justine

2 Likes

Hi Justine!

Thank you for your prompt response and for your suggestions. No matter what I do, either it’s with the DADA2 plugin or Deblur, I still keep getting the plugin error. I’ve tried to go through the tutorials and follow closely with the techniques used to filter trim length but I get the error no matter what length I choose. I’m not sure if this is because there is only one trim length that can be chosen or because there is something else going on. I took a snapshot of the error below with DADA2. In this case, I fiddled with the trim lengths a little and still got the same error message. I used the --verbose command to hopefully get insight on what’s going on.

Let me know what you recommend.

With gratitude,
-Hasti

Hi @Hasti_A,

This is a memory error. You may need to look into allocating more memory for your virtual box. You may want to look at this previous thread.

Best,
Justine

Hi Justine,

Thank you for taking the time to respond! Perfect, yes this seemed to be the error. After allocating more memory on my virtual box, the command ended up running successfully. Thank you again for all your help, I truly appreciate it.

With gratitude,
Hasti

1 Like