SEPP error message when following PICRUST tutorial

Hello Team Picrust,

I am new to Picrust and trying to run the example data set following the commands on, but when I run the command - " qiime fragment-insertion sepp --i-representative-sequences mammal_seqs.qza --i-reference-database picrust2_default_sepp_ref.qza --output-dir tutorial_placed_out --p-threads 1 "

This error pops up:

Plugin error from fragment-insertion:

Command ‘[‘’, ‘/tmp/qiime2-archive-j0r63x6r/38a5d748-739e-44d1-b547-a35c0c8b8f29/data/dna-sequences.fasta’, ‘q2-fragment-insertion’, ‘-x’, ‘1’, ‘-A’, ‘1000’, ‘-P’, ‘5000’, ‘-a’, ‘/tmp/qiime2-archive-dge6cgsp/2028ee20-c65b-470e-9cf5-80e2b4e28d0d/data/aligned-dna-sequences.fasta’, ‘-t’, ‘/tmp/qiime2-archive-dge6cgsp/2028ee20-c65b-470e-9cf5-80e2b4e28d0d/data/tree.nwk’, ‘-r’, ‘/tmp/qiime2-archive-dge6cgsp/2028ee20-c65b-470e-9cf5-80e2b4e28d0d/data/raxml-info.txt’]’ returned non-zero exit status 1.

What I have been missing? Is it the memory constraint? I am trying to run it on 8GB RAM as QIIME2 pluggin.

Thank you.


1 Like

Hello again @SciCatalyst,

Note: I have changed the title since this is really a SEPP error, and an error you are getting from QIIME 2, not from PICRUST itself, per se.

I am pinging @gmdouglas since these are tutorial files causing this error, in case he wants to take a look.

Given that these are tutorial files, I agree with you that this is probably a memory error, but you can follow the debugging steps in this forum topic (note the debug and verbose flags) to get more diagnostic details:

let us know what you find!

1 Like

Thank you for your prompt reply @Nicholas_Bokulich.
I tried with what is mentioned in the post you indicated, but I could not see what the actual problem is because I am using the example dataset in this link “”.
I will try running it on a system with higher specifications and will get back to you soon.

Thank you.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.