Segmentation fault importing sequences with manifest file

I was attempting to import single end sequences using a manifest file (Qiime version 2020.6). Here is the command:

qiime tools import \
  --type 'SampleData[SequencesWithQuality]' \
  --input-path level36_manifest \
  --output-path L3L6-demux.qza \
  --input-format SingleEndFastqManifestPhred33V2

This produced the following error:

/opt/nesi/CS400_centos7_bdw/QIIME2/2020.6/lib/python3.6/importlib/ RuntimeWarning: compiletime version 3.7 of module 'mtrand' does not match runtime version 3.6
  return f(*args, **kwds)
Segmentation fault

I then tried with version 2020.2, and it worked fine. Qiime2 was installed as a module on our national server (New Zealand). I have requested them to install latest version (2020.8), but would be good to know how this bug arose.



Hi @hugh!

This is the interesting part of the error message, I think what it is implying is that somehow you are mixing two different versions of Python: 3.6 (used by QIIME 2), and 3.7. Usually in cases like this it is because the user (or sysadmin) has set up the environment in a way that allows for these environments to mix, accidentally. A common case is setting a PYTHONPATH env var, for example. You might want to check with the sysadmins of this system to see if they have some specific requirements about setting up your computational env.

Hope that helps!


PS - in the meantime, you can activate the QIIME 2 environment and run the env command, and share the results here, happy to take a peek.

1 Like

Many thanks for the response. You were right. I went back and check with module list and there was a version of Python (3.7) also loaded. I had used Seqmagick to clean up the sequences prior to import, and it must have loaded with that. Here is a friendly tip for those who can learn from my mistake: If on a server, it is good practice to purge the existing modules before loading the Qiime2 module:

module purge
module load QIIME2/2020.6

After purging and reloading just Qiime2 2020.6, it worked without a problem.



This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.