Segmentation fault: 11 qiime2-2019.1 diversity alpha-rarefaction

Hi,
qiime diversity alpha-rarefaction pipeline in qiime2-2019.1 terminates and displays this message “Segmentation fault: 11”.

I have tried this several times but no success yet. Is this a qiime2 issue or a hard ware issue?
using mojave 10.14.6 on a 16GB memory MacBook Pro

Any help?

My guess is you are running out of memory, although, I can’t be sure without:

  • The full command you ran
  • The complete error message received

Hello @thermokarst
I used the following commands

qiime diversity alpha-rarefaction --i-table my_table.qza --p-max-depth 30000 --i-phylogeny rooted_tree.qza --m-metadata-file metadata.tsv --o-visualization rarefaction_curve --p-steps 20

It just terminate after some minutes and displays “Segmentation fault: 11”. There are no other error messsages

My guess is you are running out of memory here, but I am not sure.

This may also be related so some of the things we saw in earlier versions of the new unifrac implementation under heavy load. Those problems were fixed in the latest release. I would recommend updating to 2019.7 and trying the command again.

Hi,

I am also seeing the same error code (Segmentation fault: 11) after running the following command:

$ qiime diversity alpha-rarefaction \

–i-table table.qza
–i-phylogeny rooted-tree.qza
–p-max-depth 5000
–m-metadata-file sample-metadata.txt
–o-visualization alpha-rarefaction-5000.qzv

My system is also a macOS Mojave ver10.14.6, qiime2-2019.7.

I have previously ran the same command on two other sample sets but no such error message. I combined both data sets and the error message appeared.

Any help?

Hi @mickohy, echoing what I mentioned above:

Any chance you can get access to more memory?