SCNIC not working with low number of samples

Dear qiime2 developers,

When trying to run calculate_correlations.py (q2-SCNIC) on a dataset with 8 samples, it fails with the error message below, however when I run it with a larger dataset of 24 samples, it works with no error

Is there anyway I can force calculate_correlations.py to run with a dataset of 8 samples, as I have four different treatment groups, each of 8 samples.

Thank you for your help,
Jennifer

Plugin error from SCNIC:

File b’/tmp/fastsparyho83ijs/correl_table.tsv’ does not exist

Debug info has been saved to /tmp/qiime2-q2cli-err-1cfm7j00.log

Hi @JenKelly,

I am not an expert on SCNIC, but I’ll try a guess!
So you have a dataset of 24 samples, which you can process with SCNIC. Then you want to select 8 of these samples to run separately, but you are not able to do that.
If my understanding is correct, how did you get the 8 sample set? Which command did you use and did you visualize them to see if these are what you want?

Cheers
Luca

Hi @llenzi,

Thanks for the reply. The three sets of 8 samples are simply different three different diets, so I just filtered the ASV table to get three separate ASV tables, 1 per diet. I have summarised and visualised these to check there are correct number of samples, which there are, and that I didn’t filtered out all my features, which I havn’t.

I only tried running the full set of 24 samples because I saw another post indicated the error I was getting was due to low sample number, so I was testing that, and turned out that was right. It ran with larger dataset of 24 samples but not a small dataset of 8 samples.

Thank you,
Jennifer

Hi @JenKelly
that would make sense than, and unfortunately I am not able to help! Let see if anybody else may suggest a way … Sorry
Luca