scikit learn version in feature-classifier

Hi,
I have a problem the I try to run feature-classifier

I use qiime2-2020.8 under conda environment

When I try to classify my results a message error appears
(qiime2-2020.8) [email protected]:~$ qiime feature-classifier classify-sklearn --i-classifier /Users/slegall/Downloads/silva-132-99-nb-classifier.qza --i-reads /Users/slegall/Desktop/16S\ souris\ Thomas/dada-denoise-filter_seq.qza --o-classification /Users/slegall/Desktop/16S\ souris\ Thomas/silva99taxonomy.qza

Plugin error from feature-classifier:

The scikit-learn version (0.20.2) used to generate this artifact does not match the current version of scikit-learn installed (0.23.1). Please retrain your classifier for your current deployment to prevent data-corruption errors.

Debug info has been saved to /var/folders/x6/hrwk6kxx3gv67dj_x6s4cglxmt33k8/T/qiime2-q2cli-err-jwijwd.log

Can you help me please

Regards
Sandrine

Please read the following before posting!

Is this post about a Technical Support Question? Those include error messages observed while running QIIME 2, errors observed while installing QIIME 2, or any other "software" related problem or bug. Please do not post questions here that have to do with interpretation of results, or general discussion.

Before posting, please make sure you have the following information available, in order for us to help you in a timely manner:

  • Have you searched for the problem on the forum? It is rare that we see a new question asked, so make sure you do your homework before asking for us to commit our time to helping you.
  • Have you reviewed the QIIME 2 Forum Glossary?
  • Version of QIIME 2 you are running, and how it is installed (e.g. Virtualbox, conda, etc.)
  • What is the exact command or commands you ran? Copy and paste please.
  • What is the exact error message? If you didn't run the command with the --verbose flag, please re-run and copy-and-paste the results.

Good morning, Sandrine,

Here's the core of the error:

Looks like you are using an older classifier artifact with a newer version of Qiime2. The easy solution is to download a new pre-trained classifier that matches your version of Qiime2.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.