Scikit-learn and classifier versions issue for V4-V5

Hi Technical Support,

I am having issues with scikit-learn versions.

Background: I am trying to run lower version scikit-learn version 0.19.1 with qiime2-2019.4 to train classifier with my data. But still the issue is not resolved.

Issue generated with Qiime2-2019.7

The scikit-learn version (0.19.1) used to generate this artifact does not match the current version of scikit-learn installed (0.20.2). Please retrain your classifier for your current deployment to prevent data-corruption errors.


Do I need to run it from the top, since everything was done using QIIME2-2019.7 up until the error I got with version scikit-learn 0.20.2 which require a lower version?

Thank you,

1 Like

This happens with new versions, for some reason, I think it’s because scikit-learn gets uploaded w/ versions, you have to retrain your classifiers every time scikit-learn gets updated w/ QIIME2 versions.

In this case, I think your classifier was trained using 2019.4, but your current version is expecting a classifier trained in 2019.7 -> I’m not sure if there’s anything around retraining your classifier.


1 Like

Hi Ben,
I did downgrade to match with Scikit-learn 0.19.1 but it still returns with error report.

1 Like

Yeah, I think it would be best to retrain your classifier on the current version you’re using (2019.7). There’s some weird incompatibility in classifiers when you use a new version of QIIME hat is current beyond my understanding. Ben