Sample metadata- Core metrics phylogenetic error


I'm working with sequenced-samples which I worked in a Miseq using two index adapter Nextera XT v2 Index Kit A. The problem appeared when I tried to run the core-metrics-phylogenetic plugin:

"Plugin error from diversity:

None of the sample identifiers match between the metadata and the coordinates. Verify that you are using metadata and coordinates corresponding to the same dataset."

I checked my sample-metadata.tsv with keemei and it's seems that the format is ok.

what's going wrong?

Thanks!! !sample_metadata_double_index

Hey there @leonardo467!

The Sample IDs in your metadata are not 100% matching your Sample IDs in your Feature Table provided as input to core-metrics-phylogenetic. Can you share your feature-table summarize results? You will almost certainly need to run the command sans metadata.


Hi @thermokarst!

Sorry for my late answer, I figured out that I make a mistake on my sample ID on my metadata.

In the computer of the MiSeq I labeled my samples as β€œ01,02,03…”. The problem was when I opened the metadata generated by the machine in Libre Office because my sample β€œ01” appeared as β€œ1” and so on. So when I run the command it appeared as if they were samples missing. I had to modify my metadata by writing the sample ID’s as text in order to be able to write β€œ01” in Libre Office. In that way qiime was able to detect my samples and perform correctly the analysis!

Thanks anyway!! :lizard:

Yep, this is consistent with what I mentioned above, your IDs must match exactly. Glad to see you got things cleaned up. Have fun!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.