RESCRIPt: problem installing dependencies


I am having issues installing the dependencies required for RESCRIPt within the Qiime2 environment.

I ran the following commands:

conda activate qiime2-2023.2
conda install -c conda-forge -c bioconda -c qiime2 -c 2023.5-tested -c defaults
xmltodict 'q2-types-genomics>2023.2' ncbi-datasets-pylib

But the installation fails with the following messages:

Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: ...

and then lists a whole load of package conflicts

I am running it on a M1 mac. I installed Qiime2 using the M1 version of Anaconda3 via the instructions given for MacOS (Apple Silicon).

Thanks for any insight!

1 Like

Hi @aghudson ,

My guess is that other plugins or packages were installed in that environment, leading to the conflict. RESCRIPt should not have issues installing in a fresh 2023.2 environment (unless if some dependency packages were changed on the conda side, which could happen).

You should try installing in a fresh environment, or create a minimal RESCRIPt environment (following the instructions on GitHub) to avoid dependency conflicts with other plugins that you have installed.

Let me know if you still experience issues with a fresh environment or minimal environment! Good luck!

1 Like

Thanks for the suggestion. I tried the minimal install and I got a different error message. It appears to not be able to find a lot of neccessary packages. From the channels it looks in but finds nothing, could this be an issue with RESCRIPt and compatibility with the M1 Conda install?

"PackagesNotFoundError: The following packages are not available from current channels:

  • q2cli
  • qiime2
  • q2-longitudinal
  • q2templates
  • q2-types-genomics[version='>2023.2']
  • q2-feature-classifier
  • q2-types

Current channels:

Hi @aghudson,

Are you sure your in the "minimal install" rescript environment. I often see the errors you've posted when I am accidentally trying to run the conda install ... commands in my base or other environment.

I just ran each of these separately on my M1 MacBook Pro, and everything worked as advertised

conda create -y -n rescript
conda activate rescript
conda install \
  -c conda-forge -c bioconda -c qiime2 -c -c defaults \
  qiime2 q2cli q2templates q2-types q2-longitudinal q2-feature-classifier 'q2-types-genomics>2023.2' \
  "pandas>=0.25.3" xmltodict ncbi-datasets-pylib

Hi @SoilRotifer,

Following your suggestion, I removed the old RESCRIPt minimal environment I had installed and tried reinstalling following the instructions from GitHub.

Unfortunately, I get the same error message as I posted previously

Hi @aghudson ,
It looks like you are having issues more broadly with conda and with installing QIIME 2 in general, not just RESCRIPt:

So let's close this topic and wait for the other to resolve. If you are still having issues with RESCRIPt after that other topic is solved, please feel free to re-open this. But for now I would consider these duplicate posts, as they almost certainly stem from the same issue.


Hi @Nicholas_Bokulich,

I think I have come up with a solution with the overall Qiime2 installation (please see my reply in the thread). I havenʻt tested it extensively, but the installation ran to completion and I can load the Qiime2 conda environment without any error messages. I obviously canʻt rule out that this is not still causing the ongoing issues with RESCRIPt though.

1 Like

Typing "qiime --help" reveals no issues. I just can't install RESCRIPt

Could this be an issue with the MacOS version I am using (13.2.1)?

Hi @aghudson ,
Just to clarify: are you getting the same error message as before, or has the message changed now that you have QIIME 2 working?

One more idea: you could try using mamba instead of conda, it tends to solve environments much faster than conda (or at least might give a clearer error message)

Hi @Nicholas_Bokulich,

For the minimal RESCRIPt install, I get the same error message posted above.

For the Qiime2 environment installation, I am not sure. I only see a portion of the error message in the terminal, which is just a long list of the packages that are showing conflicts. Many of the conflicts I can see in the latest attempt, seem to be related to R or R-bioconductor.

Hi @aghudson ,

We are not able to reproduce this error, unfortunately, including @SoilRotifer who is also using an M1 mac. So I think that your conda configs might still be messed up.

Did you try mamba?

1 Like

I basically gave up with my M1 mac and tried installing everything on an older Intel Macbook that has never had Qiime2 installed on it, though it has a version of Miniconda installed.

I followed the Qiime2 installation instructions for Intel Mac (version: qiime2-2023.2), including updating conda. Everything ran/installed ok. In the Qiime2 conda environment I had just created, I attempted to install RESCRIPt.

I ran the following command to install dependencies:

conda install -c conda-forge -c bioconda -c qiime2 -c 2023.5-tested -c defaults
xmltodict 'q2-types-genomics>2023.2' ncbi-datasets-pylib

Unfortunately, I get pretty much the same error message. The weird thing is that a lot of the listed package conflicts are the same for the old and new macs, which I wouldn't have thought would be the case if this was to do with my current conda configuration. I can send the portions of the error messages I was able to save for both computer installations, I am just not sure what the best method of doing that might be.

I get the feeling that most of the conflicts are to do with the q2-types-genomics package as I can install the other 2 dependencies separately, but I can't prove that.

Please try to install using mamba as suggested above.

1 Like

Sorry, was reluctant to try yet another package manager and the potential conflicts that could occur.

However, I realized that mamba sort of sits on top and works with the conda environments.

I installed mamba via mambaforge and then tried following the RESCRIPt installation instructions. Mamba was much quicker and it worked!

I have no idea why it worked and conda didn't, but thanks for the advice


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.