Removing samples from metadata for taxanomic bar plots

Hi there,

I know variations of this question have been posted but there are a few things I would like to clarify…

I have come to the end of my QIIME2 pipeline and the taxa bar plots are showing the blanks/negatives that are in my metadata sheet.

Is there a way to remove the blanks/negatives from my metadata sheet or taxa bar plot?

I know there are the filtering steps (metadata based filtering), however I don’t quite understand how they work: it seems you list the samples you would like to keep rather than remove (because there are way more samples I would like to keep rather than remove, so it would be logical to state what I would like to remove instead?).

Or do I need to go way back to the beginning of the pipeline, and create a metadata sheet without those samples, and re-do analysis without the negatives in it?

Thanks for any help :grinning:

Grace

You hit the nail on the head. Check out the --p-exclude-ids flag — if you use this flag, then all the sample ids listed will be excluded, instead of included. No need to start over, just filter your table and re-reun taxa barplot on the filtered table.

1 Like

@thermokarst Thanks for the info!

The QIIME forum is so helpful :grinning:

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.