Remove unassigned phyla


I am new to qiime2, i am having a problem in removing the unassigned phyla from my taxa table.

Like i want to remove “k__Bacteria;p__;c__”

However, i tried using filter taxa commands like

qiime taxa filter-table
–i-table table-with-no-archea.qza
–i-taxonomy taxonomy.qza
–p-mode exact
–p-exclude “k__Bacteria;p__;c__”
–o-filtered-table table-no-phyla-exact.qza

But i think its not working, as i can see the unassigned phyla like “k__Bacteria;p__” in my taxa-barplots.

Thank you in advance!

Good morning,

Welcome to the Qiime 2 forums! :qiime2:

Take a look at the examples in the filtering tutorial. When I look at them, it looks like there are spaces after the semicolons ; in the --p-exclude flag.

--p-exclude "k__Bacteria; p__Proteobacteria; c__Alphaproteobacteria; o__Rickettsiales; f__mitochondria"
              space here ^

You could also try filtering one level at a time

--p-exclude "p__;"

Let me know if that helps!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.