qiime2 picrust2

Hi all,
I have tried to activate Qiime2 PICRUSt2 with the following commands:
(base) [email protected]:~$ conda activate qiime2-2019.10

(qiime2-2019.10) [email protected]:~$ conda install q2-picrust2=2019.10 -c conda-forge -c bioconda -c gavinmdouglas

It showed the output:
Collecting package metadata (current_repodata.json): done
Solving environment: done

==> WARNING: A newer version of conda exists. <==
current version: 4.8.3
latest version: 4.8.5

Please update conda by running

$ conda update -n base conda

I have run:
(qiime2-2019.10) [email protected]:~$ conda update -n base conda

Collecting package metadata (current_repodata.json): done

Solving environment: done

Proceed ([y]/n)? n

CondaSystemExit: Exiting.


Following this, I have tried to go through q2-picrust2 Running Example
qiime picrust2 full-pipeline --help

It worked well
Following several steps it showed error with this command:

  1. qiime picrust2 full-pipeline --i-table mammal_biom.qza --i-seq mammal_seqs.qza
    –output-dir q2-picrust2_output --p-threads 1 --p-hsp-method pic
    –p-max-nsti 2 --verbose
    There were some problems with the command:
    (1/3) Missing option “–o-ko-metagenome”. ("–output-dir" may also be used)
    (2/3) Missing option “–o-ec-metagenome”. ("–output-dir" may also be used)
    (3/3) Missing option “–o-pathway-abundance”. ("–output-dir" may also be
    used)

  2. Command changed, still new error:
    qiime picrust2 full-pipeline --i-table mammal_biom.qza --i-seq mammal_seqs.qza
    –p-threads 1 --p-hsp-method pic --p-max-nsti 2 --o-ko-metagenome --o-ec-metagenome --o-pathway-abundance --output-dir q2-picrust2_output --verbose
    Error:
    –p-threads: command not found

  3. qiime picrust2 full-pipeline --i-table mammal_biom.qza --i-seq mammal_seqs.qza
    –p-hsp-method pic --p-max-nsti 2 --o-ko-metagenome --o-ec-metagenome --o-pathway-abundance --output-dir q2-picrust2_output --verbose

There were some problems with the command:
(1/3) Missing option “–o-ko-metagenome”. ("–output-dir" may also be used)
(2/3) Missing option “–o-ec-metagenome”. ("–output-dir" may also be used)
(3/3) Missing option “–o-pathway-abundance”. ("–output-dir" may also be
used)

  1. qiime picrust2 full-pipeline --i-table mammal_biom.qza --i-seq mammal_seqs.qza --p-hsp-method pic --p-max-nsti 2 --o-ko-metagenome --o-ec-metagenome --o-pathway-abundance --output-dir q2-picrust2_test_full\ q2-picrust2_output --verbose

               There were some problems with the command:                  
    

(1/2?) --o-ko-metagenome option requires an argument
(2/2?) --o-pathway-abundance option requires an argument

  1. qiime picrust2 full-pipeline --i-table mammal_biom.qza --i-seq mammal_seqs.qza --p-hsp-method pic --p-max-nsti 2 --o-ko-metagenome --output-dir q2-picrust2_test_full\ q2-picrust2_output --o-ec-metagenome --output-dir q2-picrust2_test_full\ q2-picrust2_output --o-pathway-abundance --output-dir q2-picrust2_test_full\ q2-picrust2_output --verbose

There were some problems with the command:
(1/3?) --o-ko-metagenome option requires an argument
(2/3?) --o-ec-metagenome option requires an argument
(3/3?) --o-pathway-abundance option requires an argument

I am not understanding what are the wrong I am doing with commands!
Could anyone please explain?

Hi, I think you should provide or output directory or output file names in this command, but not both of this options together

1 Like

I have tried with those but still different errors came out. Please see other errors 2,3,4.

Hi all, could you please suggest something?
I am badly in need of help on this issue!

Hi @Mehrbod_Estaki,
I have found you working on Qiime2Picrust2, I read your opinion in the forum. Could you please suggest me something?

Hi @Mashuk,
I’d like to suggest you take a second look at the Forum’s Cod of Conduct, especially about the part about being patient. We are all providing help on a volunteer basis so repeated posting and tagging moderators is usually not a good idea.

That being said, @timanix has already provided you with the answer

Your commands should either include --output-dir with a directory name, at which point the 3 outputs will go into, or you’ll need to include all 3 output options separately and provide a file name. Not both as you’ve done. If you follow the official tutorial you should be able to avoid such problems.

3 Likes

Thank you for your suggestion.
I am sorry about the code of conduct issue.

1 Like