Qiime2 on AWS - can't access Jupyter Notebook

Hi all,

Trying to set up Qiime2 2017.10 on AWS using the community ami. all went well, except it cant access the notebook server. I have port 8888 (TCP) open, so I don’t think that’s the problem.

when I run jupyter notebook, im getting the following error:
"TERMCAP", line 20, col 1, terminal 'SC': Missing separator

any ideas?

Edit :
Also - tried running a local host on the same port with python -m http.server 8888 and could access with no issues. I’m guessing this is a jupyter issue, but can’t seem to find what it is exactly.

Hi @Gil_Sharon!

Does this mean you have opened up the port for the the necessary protocol via AWS’s security groups? If not, I would double check there.

Googling this error seems to point at screen, which we don’t wrap or autolaunch in the EC2 instances - are you using screen to keep your notebook running?

By default, jupyter-notebook only binds to localhost — if you bind to 0.0.0.0 you should be good to go (assuming your ec2 security group and ufw firewall all have 8888 TCP open):

(qiime2-2017.10) [email protected]:~$ jupyter-notebook --ip 0.0.0.0
[I 17:26:11.854 NotebookApp] Serving notebooks from local directory: /home/qiime2
[I 17:26:11.855 NotebookApp] 0 active kernels
[I 17:26:11.855 NotebookApp] The Jupyter Notebook is running at:
[I 17:26:11.855 NotebookApp] http://0.0.0.0:8888/?token=8f1881c4d5ca988904fc0a7d429c8d999964ec1c4e0abbf1
[I 17:26:11.856 NotebookApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation).
[W 17:26:11.856 NotebookApp] No web browser found: could not locate runnable browser.
[C 17:26:11.857 NotebookApp]

    Copy/paste this URL into your browser when you connect for the first time,
    to login with a token:
        http://0.0.0.0:8888/?token=8f1881c4d5ca988904fc0a7d429c8d999964ec1c4e0abbf1

Copy and paste the login url, but replace the 0.0.0.0 portion with your public IP. e.g. http://52.12.211.153:8888/?token=8f1881c4d5ca988904fc0a7d429c8d999964ec1c4e0abbf1

If you are still having problems, your best bet is to coordinate with the jupyter support team — we can’t really provide support for that tool, since it isn’t developed by us. Feel free to update this thread here if you learn anything interesting! :t_rex:

1 Like

Thanks! Indeed I had screen running and that was the source of that error. Binding to 0.0.0.0 worked.

Clearly, this was not related to qiime or its ami… Thanks for the help!

Gil

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.