QIIME2 Installation ResolvePackageNotFound Error

install

(dong yang) #1

Hi QIIME2 support team,

I have been working to install QIIME2 using Anaconda Prompt on my windows computer , and I keep getting the following error:

(base) C:\Users\AI>conda env create -n qiime2-2018.11 --file qiime2-2018.11-py35-linux-conda.yml
Solving environment: failed

ResolvePackageNotFound:
  - q2-phylogeny=2018.11.0
  - q2-vsearch=2018.11.0
  - unifrac=0.9.2
  - perl-parent=0.236
  - perl-encode=2.88
  - perl-extutils-makemaker=7.34
  - perl-list-moreutils-xs=0.428
  - qiime2=2018.11.0
  - perl-exporter-tiny=1.000000
  - gneiss=0.4.4
  - scikit-bio[version='>=0.5.1']
  - dbus=1.13.0
  - scikit-bio=0.5.4
  - perl-io-zlib=1.10
  - bioconductor-zlibbioc=1.24.0
  - emperor=1.0.0beta18
  - q2-quality-filter=2018.11.0
  - libuuid=2.32.1
  - perl-xsloader=0.24
  - fragment-insertion=4.3.5
  - nettle=3.3
  - q2cli=2018.11.0
  - bioconductor-s4vectors=0.16.0
  - bioconductor-genomeinfodb=1.14.0
  - perl-carp=1.38
  - gst-plugins-base=1.12.5
  - wget=1.19.5
  - q2-metadata=2018.11.0
  - raxml=8.2.12
  - q2-dada2=2018.11.0
  - perl-compress-raw-zlib=2.081
  - bioconductor-iranges=2.12.0
  - q2-sample-classifier=2018.11.0
  - perl-scalar-list-utils=1.45
  - perl-data-dumper=2.161
  - gmp=6.1.2
  - q2-diversity=2018.11.0
  - cutadapt=1.18
  - fasttree=2.1.10
  - bioconductor-genomeinfodbdata=1.0.0
  - bioconductor-genomicalignments=1.14.1
  - q2-quality-control=2018.11.0
  - q2-alignment=2018.11.0
  - q2-types=2018.11.0
  - libgfortran=3.0.0
  - q2-feature-table=2018.11.0
  - perl-io-compress=2.069
  - bioconductor-biocgenerics=0.24.0
  - bioconductor-biostrings=2.46.0
  - q2-taxa=2018.11.0
  - q2-cutadapt=2018.11.0
  - bioconductor-delayedarray=0.4.1
  - libgcc-ng=7.2.0
  - q2-composition=2018.11.0
  - ncurses=6.1
  - sina=1.4.0
  - q2-deblur=2018.11.0
  - libarbdb=6.0.6
  - libgfortran-ng=7.2.0
  - ptyprocess=0.6.0
  - perl-list-moreutils=0.428
  - q2-feature-classifier=2018.11.0
  - blast=2.7.1
  - perl-exporter=5.72
  - sortmerna=2.0
  - bioconductor-dada2=1.6.0
  - gstreamer=1.12.5
  - q2-demux=2018.11.0
  - bioconductor-biocparallel=1.12.0
  - gnutls=3.5.19
  - q2-emperor=2018.11.0
  - mafft=7.310
  - q2-longitudinal=2018.11.0
  - q2templates=2018.11.0
  - arb-bio-tools=6.0.6
  - bioconductor-summarizedexperiment=1.8.0
  - hdmedians=0.13
  - pango=1.40.14
  - perl-archive-tar=2.32
  - deblur=1.1.0
  - java-jdk=8.0.92
  - bioconductor-rsamtools=1.30.0
  - perl-test-more=1.001002
  - libstdcxx-ng=7.2.0
  - perl-pathtools=3.73
  - bioconductor-genomicranges=1.30.3
  - readline=7.0
  - bioconductor-xvector=0.18.0
  - vsearch=2.7.0
  - bioconductor-shortread=1.36.0
  - libgcc=7.2.0
  - q2-fragment-insertion=2018.11.0
  - iqtree=1.6.8
  - bioconductor-biobase=2.38.0
  - q2-gneiss=2018.11.0
  - perl-compress-raw-bzip2=2.081

BTW, when I tried to download the .yml using wget, an error occurs:

(base) C:\Users\AI>wget https://data.qiime2.org/distro/core/qiime2-2018.11-py35-linux-conda.yml
--2019-01-09 11:19:32--  https://data.qiime2.org/distro/core/qiime2-2018.11-py35-linux-conda.yml
Resolving data.qiime2.org (data.qiime2.org)... 104.27.170.158, 104.27.171.158
Connecting to data.qiime2.org (data.qiime2.org)|104.27.170.158|:443... connected.
ERROR: cannot verify data.qiime2.org's certificate, issued by 'CN=COMODO ECC Domain Validation Secure Server CA 2,O=COMODO CA Limited,L=Salford,ST=Greater Manchester,C=GB':
  Unable to locally verify the issuer's authority.
To connect to data.qiime2.org insecurely, use `--no-check-certificate'.

But I think I overcome this problem by using --no-check-certificate. I am not sure if this is an potential cause:

(base) C:\Users\AI>wget https://data.qiime2.org/distro/core/qiime2-2018.11-py35-linux-conda.yml --no-check-certificate
--2019-01-09 11:24:01--  https://data.qiime2.org/distro/core/qiime2-2018.11-py35-linux-conda.yml
Resolving data.qiime2.org (data.qiime2.org)... 104.27.170.158, 104.27.171.158
Connecting to data.qiime2.org (data.qiime2.org)|104.27.170.158|:443... connected.
WARNING: cannot verify data.qiime2.org's certificate, issued by 'CN=COMODO ECC Domain Validation Secure Server CA 2,O=COMODO CA Limited,L=Salford,ST=Greater Manchester,C=GB':
  Unable to locally verify the issuer's authority.
HTTP request sent, awaiting response... 302 FOUND
Location: https://raw.githubusercontent.com/qiime2/environment-files/master/2018.11/release/qiime2-2018.11-py35-linux-conda.yml [following]
--2019-01-09 11:24:01--  https://raw.githubusercontent.com/qiime2/environment-files/master/2018.11/release/qiime2-2018.11-py35-linux-conda.yml
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.116.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.116.133|:443... connected.
WARNING: cannot verify raw.githubusercontent.com's certificate, issued by 'CN=DigiCert SHA2 High Assurance Server CA,OU=www.digicert.com,O=DigiCert Inc,C=US':
  Unable to locally verify the issuer's authority.
HTTP request sent, awaiting response... 200 OK
Length: 5663 (5.5K) [text/plain]
Saving to: 'qiime2-2018.11-py35-linux-conda.yml.1'

qiime2-2018.11-py35-linux-con 100%[===================================================>]   5.53K  --.-KB/s   in 0.02s

2019-01-09 11:24:01 (363 KB/s) - 'qiime2-2018.11-py35-linux-conda.yml.1' saved [5663/5663]

(Evan Bolyen) assigned ebolyen #2

(Evan Bolyen) #3

Hi @dong!

I think the certificate failure (while odd) is a bit of a red-herring here.

The Anaconda Prompt will install these packages as Windows builds, however Windows builds are not available for many of the bioinformatics tools QIIME 2 relies on.

This means you need to use a different kind of terminal on Windows. There are a few options:

If you are using Window 10 with the HyperV feature enabled (only available on Pro, Government, or Educational variants of Windows 10). You can use either:

  • Windows Subsystem for Linux (this is probably the easiest option)

    • Your Windows files are available under /mnt/c/ within this subsystem, but Windows cannot see the linux files.
  • Docker for Windows (Very flexible, but slightly harder to use as it is a sysadmin/dev tool primarily).

    • You have to set up a volume mount yourself, but the same rules apply w.r.t. file visibility.

If you are not using Windows 10, then you will need to use VirtualBox.

Note: HyperV and VirtualBox are incompatible, so if you have to use VirtualBox for other reasons, then stick with that tool. Otherwise you will find yourself rebooting Windows a lot to enable/disable HyperV which is annoying.


(Evan Bolyen) unassigned ebolyen #4

(dong yang) #5

Now I have installed it on linux and it worked.