QIIME2 installation problems, Mac book pro M1 max

Dear all,

I am the beginner of bioinformatic and Mac user.
I have been trying to install QIIME2 on my new computer (Mac book pro, M1 max).
Before install, I also install Miniconda3 (Miniconda3 macOS Apple M1 64-bit bash; Python 3.9.12), and wget.
Then, I tried to starting to QIIME2 installation such as following:
a) wget https://data.qiime2.org/distro/core/qiime2-2022.8-py38-osx-conda.yml —> the result was good.

(base) ~MacDownloads % conda env create -n qiime2-2022.8 --file qiime2-2022.8-py38-osx-conda.yml
Collecting package metadata (repodata.json): done
Solving environment: failed


  • perl-compress-raw-bzip2=2.201
  • xopen=1.6.0
  • qiime2=2022.8.3
  • emperor=1.0.3
  • q2galaxy=2022.8.1
  • q2-diversity-lib=2022.8.0
  • htslib=1.15.1
  • fasttree=2.1.11
  • r-interp=1.1_3
  • biom-format=2.1.12
  • q2-composition=2022.8.0
  • bioconductor-dada2=1.22.0
  • q2-gneiss=2022.8.0
  • perl-encode=3.19
  • sepp=4.3.10
  • blast=2.12.0
  • q2-dada2=2022.8.0
  • samtools=1.15.1
  • entrez-direct=16.2
  • gfortran_impl_osx-64=9.5.0
  • iqtree=
  • r-rcurl=1.98_1.8
  • scikit-bio=0.5.7
  • perl-json-xs=2.34
  • iow=1.0.5
  • bioconductor-delayedarray=0.20.0
  • unifrac=1.1.1
  • cutadapt=4.1
  • perl-scalar-list-utils=1.63
  • perl-pathtools=3.75
  • q2-metadata=2022.8.0
  • bioconductor-genomicranges=1.46.1
  • mafft=7.505
  • q2-taxa=2022.8.0
  • vsearch=2.21.1
  • q2-feature-classifier=2022.8.0
  • sortmerna=2.0
  • q2-mystery-stew=2022.8.0
  • bioconductor-zlibbioc=1.40.0
  • isa-l=2.30.0
  • q2-fragment-insertion=2022.8.0
  • raxml=8.2.12
  • python-isal=1.0.1
  • r-jpeg=0.1_9
  • q2-alignment=2022.8.0
  • r-vegan=2.6_2
  • bioconductor-rhtslib=1.26.0
  • q2-deblur=2022.8.0
  • q2cli=2022.8.0
  • pbzip2=1.1.13
  • bioconductor-biocparallel=1.28.3
  • gfortran_osx-64=9.5.0
  • bioconductor-s4vectors=0.32.3
  • q2-cutadapt=2022.8.0
  • bioconductor-xvector=0.34.0
  • q2-longitudinal=2022.8.0
  • q2-demux=2022.8.0
  • bowtie2=2.4.5
  • fastcluster=1.2.6
  • bioconductor-shortread=1.52.0
  • bioconductor-genomicalignments=1.30.0
  • q2-sample-classifier=2022.8.0
  • q2-diversity=2022.8.0
  • q2-emperor=2022.8.0
  • q2-phylogeny=2022.8.0
  • bioconductor-iranges=2.28.0
  • perl-compress-raw-zlib=2.202
  • hmmer=3.1b2
  • q2-quality-filter=2022.8.0
  • q2templates=2022.8.0
  • perl-list-moreutils-xs=0.430
  • q2-vsearch=2022.8.0
  • bioconductor-biostrings=2.62.0
  • q2-types=2022.8.0
  • bioconductor-rsamtools=2.10.0
  • unifrac-binaries=1.1.1
  • bioconductor-biobase=2.54.0
  • dnaio=0.9.1
  • perl-io-compress=2.106
  • q2-quality-control=2022.8.0
  • q2-feature-table=2022.8.1

I tried to re-install another miniconda3 (Miniconda3 macOS Apple M1 ARM 64-bit bash, Python3.8), but didn’t work well.

How can I do next. I wish your comment.

Hi @Hironori_Fukuoka, welcome to :qiime2:

If you search the forum you'll find several threads related to this. You can start here:

Hey @Hironori_Fukuoka!

Piggybacking off of @SoilRotifer - I wanted to share that I submitted an update to our docs that includes install instructions for Macs with M1 chips. You can view that code change here, for reference. Here's how you should install QIIME 2 using conda on an M1 Mac:

wget https://data.qiime2.org/distro/core/qiime2-2022.8-py38-osx-conda.yml
CONDA_SUBDIR=osx-64 conda env create -n qiime2-2022.8 --file qiime2-2022.11-py38-osx-conda.yml
conda activate qiime2-2022.8
conda config --env --set subdir osx-64

Cheers :lizard:


Dear @lizgehret

Thank you for your kind advice such the following code.
I tried code, but the following message was given.

(base) ~Mac~. % wget https://data.qiime2.org/distro/core/qiime2-2022.8-py38-osx-conda.yml
--2022-10-13 14:15:59-- https://data.qiime2.org/distro/core/qiime2-2022.8-py38-osx-conda.yml
Resolving data.qiime2.org (data.qiime2.org)...
Connecting to data.qiime2.org (data.qiime2.org)||:443... connected.
HTTP request sent, awaiting response... 302 FOUND
Location: https://raw.githubusercontent.com/qiime2/environment-files/master/2022.8/release/qiime2-2022.8-py38-osx-conda.yml [following]
--2022-10-13 14:15:59-- https://raw.githubusercontent.com/qiime2/environment-files/master/2022.8/release/qiime2-2022.8-py38-osx-conda.yml
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 2606:50c0:8003::154, 2606:50c0:8002::154, 2606:50c0:8000::154, ...
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|2606:50c0:8003::154|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 8573 (8.4K) [text/plain]
Saving to: 'qiime2-2022.8-py38-osx-conda.yml.2'

qiime2-2022.8-py38-osx-conda.yml.2 100%[============================================================================================================================>] 8.37K --.-KB/s in 0s

2022-10-13 14:16:00 (18.2 MB/s) - 'qiime2-2022.8-py38-osx-conda.yml.2' saved [8573/8573]

(base) ~Mac ~ % CONDA_SUBDIR=osx-64 conda env create -n qiime2-2022.8 --file qiime2-2022.11-py38-osx-conda.yml

SpecNotFound: Invalid name 'qiime2-2022.8', try the format: user/package

Do you know where I mistook?

Dear @SoilRotifer

Thank you for your rapid and kind response.
I would try installation via your advise.
Thank you very much.


1 Like

Dear @SoilRotifer @lizgehret

Thank you for your advice.
Finally I can install qiime2 via the following command.

CONDA_SUBDIR=osx-64 conda env create -n qiime2-2022.8 --file qiime2-2022.8-py38-osx-conda.yml
conda activate qiime2-2022.8
conda config --env --set subdir osx-64

Thank you! If I confuse again, I hope your help again.



1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.