Qiime2 can not installed in Conda envrionment. (ERROR conda.core.link:_execute(952))

I am using M1 mac.

I installed Anaconda3 and installed qiime2-2022.11.
I followed the manual and got the following error.
By the way, I got the same error code with miniconda3.

(base) taitoiMac:~ taito$ wget https://data.qiime2.org/distro/core/qiime2-2023.5-py38-osx-conda.yml
--2023-07-16 16:28:10-- https://data.qiime2.org/distro/core/qiime2-2023.5-py38-osx-conda.yml
Resolving data.qiime2.org (data.qiime2.org)...
Connecting to data.qiime2.org (data.qiime2.org)||:443... connected.
HTTP request sent, awaiting response... 302 FOUND
Location: https://raw.githubusercontent.com/qiime2/environment-files/master/2023.5/release/qiime2-2023.5-py38-osx-conda.yml [following]
--2023-07-16 16:28:11-- https://raw.githubusercontent.com/qiime2/environment-files/master/2023.5/release/qiime2-2023.5-py38-osx-conda.yml
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 2606:50c0:8003::154, 2606:50c0:8000::154, 2606:50c0:8001::154, ...
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|2606:50c0:8003::154|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 14006 (14K) [text/plain]
Saving to: 'qiime2-2023.5-py38-osx-conda.yml'

qiime2-2023.5-py38- 100%[===================>] 13.68K --.-KB/s in 0s

2023-07-16 16:28:12 (32.1 MB/s) - 'qiime2-2023.5-py38-osx-conda.yml' saved [14006/14006]

(base) taitoiMac:~ taito$ CONDA_SUBDIR=osx-64 conda env create -n qiime2-2023.5 --file qiime2-2023.5-py38-osx-conda.yml
Collecting package metadata (repodata.json): done
Solving environment: done

Downloading and Extracting Packages

Preparing transaction: done
Verifying transaction: done
Executing transaction: done
ERROR conda.core.link:_execute(952): An error occurred while installing package 'bioconda::bioconductor-genomeinfodbdata-1.2.9-r42hdfd78af_0'.
Rolling back transaction: done

LinkError: post-link script failed for package bioconda::bioconductor-genomeinfodbdata-1.2.9-r42hdfd78af_0
location of failed script: /Users/taito/anaconda3/envs/qiime2-2023.5/bin/.bioconductor-genomeinfodbdata-post-link.sh
==> script messages <==

==> script output <==
stderr: /Users/taito/anaconda3/envs/qiime2-2023.5/bin/tab-qiime: /Users/taito/anaconda3/envs/qiime2-2023.5/bin/qiime: /Users/taito/anaconda3/envs/qiime2-2023.5/bin/python: bad interpreter: Bad CPU type in executable
++ dirname -- /Users/taito/anaconda3/envs/qiime2-2023.5/bin/installBiocDataPackage.sh

  • SCRIPT_DIR=/Users/taito/anaconda3/envs/qiime2-2023.5/bin/../share/bioconductor-data-packages
  • json=/Users/taito/anaconda3/envs/qiime2-2023.5/bin/../share/bioconductor-data-packages/dataURLs.json
    ++ yq '."genomeinfodbdata-1.2.9".fn' /Users/taito/anaconda3/envs/qiime2-2023.5/bin/../share/bioconductor-data-packages/dataURLs.json
    /Users/taito/anaconda3/envs/qiime2-2023.5/bin/installBiocDataPackage.sh: /Users/taito/anaconda3/envs/qiime2-2023.5/bin/yq: /Users/taito/anaconda3/envs/qiime2-2023.5/bin/python3.8: bad interpreter: Bad CPU type in executable
  • FN=

return code: 126


(base) taitoiMac:~ taito$ conda info

 active environment : base
active env location : /Users/taito/anaconda3
        shell level : 1
   user config file : /Users/taito/.condarc

populated config files : /Users/taito/.condarc
conda version : 23.5.2
conda-build version : 3.25.0
python version : 3.11.3.final.0
virtual packages : __archspec=1=arm64
base environment : /Users/taito/anaconda3 (writable)
conda av data dir : /Users/taito/anaconda3/etc/conda
conda av metadata url : None
channel URLs : main/osx-arm64
package cache : /Users/taito/anaconda3/pkgs
envs directories : /Users/taito/anaconda3/envs
platform : osx-arm64
user-agent : conda/23.5.2 requests/2.29.0 CPython/3.11.3 Darwin/22.5.0 OSX/13.4.1
UID:GID : 501:20
netrc file : None
offline mode : False

I can't find out what is going on.
Could you please advise me?
Sorry for my lack of knowledge.
Thank you.

Hello @sato,

See if this post and the posts linked within it resolve your problem.


I tried to use conda clean -y --all, but the same error is displayed.
I changed the qiime2 version and got the same error.

Thank you.

Hello @sato,

One of the linked posts recommends un- and reinstalling conda. That might be your next option.

Hello @colinvwood

My conda uninstalled, I put it back in and ran it again according to the qiime2 manual.

After installing Rosseta2, I was able to put in qiime2 successfully.
Thank you Colin and my friend.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.