QIIME2 2018.4 Installation Error

If I try to install qiime2-2018.4 next to my existing qiime2-2018.2 installation using conda, I get the following error:

conda env create -n qiime2-2018.4 --file qiime2-2018.4-py35-linux-conda.yml

Solving environment: done
Preparing transaction: done
Verifying transaction: failed

CondaVerificationError: The package for vsearch located at /home/christian/miniconda3/pkgs/vsearch-2.7.0-1
appears to be corrupted. The path ‘bin/aclocal.bak’
specified in the package manifest cannot be found.

CondaVerificationError: The package for vsearch located at /home/christian/miniconda3/pkgs/vsearch-2.7.0-1
appears to be corrupted. The path ‘bin/autoheader.bak’
specified in the package manifest cannot be found.

CondaVerificationError: The package for vsearch located at /home/christian/miniconda3/pkgs/vsearch-2.7.0-1
appears to be corrupted. The path ‘bin/autom4te.bak’
specified in the package manifest cannot be found.

CondaVerificationError: The package for vsearch located at /home/christian/miniconda3/pkgs/vsearch-2.7.0-1
appears to be corrupted. The path ‘bin/automake.bak’
specified in the package manifest cannot be found.

CondaVerificationError: The package for vsearch located at /home/christian/miniconda3/pkgs/vsearch-2.7.0-1
appears to be corrupted. The path ‘bin/autoreconf.bak’
specified in the package manifest cannot be found.

CondaVerificationError: The package for vsearch located at /home/christian/miniconda3/pkgs/vsearch-2.7.0-1
appears to be corrupted. The path ‘bin/autoscan.bak’
specified in the package manifest cannot be found.

CondaVerificationError: The package for vsearch located at /home/christian/miniconda3/pkgs/vsearch-2.7.0-1
appears to be corrupted. The path ‘bin/autoupdate.bak’
specified in the package manifest cannot be found.

CondaVerificationError: The package for vsearch located at /home/christian/miniconda3/pkgs/vsearch-2.7.0-1
appears to be corrupted. The path ‘bin/ifnames.bak’
specified in the package manifest cannot be found.

ClobberWarning: This transaction has incompatible packages due to a shared path.
packages: conda-forge::gettext-0.19.8.1-0, conda-forge::gsl-2.1-2, defaults::libgcc-ng-7.2.0-hdf63c60_3, conda-forge::readline-7.0-0
path: ‘share/info/dir’

ClobberWarning: This transaction has incompatible packages due to a shared path.
packages: defaults::libgfortran-3.0.0-1, defaults::libgcc-7.2.0-h69d50b8_2
path: ‘lib/libgfortran.so.3’

…and this ClobberWarning goes on and on and on for maybe every package?

Things I tried that did not work:

  • clearing conda cache
  • adding “path_conflict: warn” to a .condarc file
  • reinstalling conda

I am pretty sure this has something to do with my python installations in my Ubuntu 16.04 VirtualBox. I tried the installation on an older QIIME2 virtualbox and it worked fine.

Has anyone else seen these errors? Is there a fix for this?

Thanks,
Christian

1 Like

Hello Christian,

I use vsearch all the time and I’m one of the folks who makes sure the vsearch conda package is working correctly.

I’m not sure if this is a conda error or compiler error (with libfortran or libgcc), but I want to hear what the Qiime devs suggest. It’s really important that the Qiime 2 installer works all the time, for everyone.

OK good. Is there something special about your python install on Ubuntu or your conda setup that could give us clues to this error?

Colin

Hi @ChristianEdwardson (and @colinbrislawn)!

This is definitely unusual, thanks for testing out these steps:


Let’s try looking at some of the more esoteric things that could be going on.

What do these commands show before activating any environment?

which python
env
conda list
conda info -a

And then, if you were to activate your qiime2-2018.2 environment, what do you see for the same commands? (You don’t need to run conda info twice).

Actually looking at it again, it kind of seems like maybe vsearch just wasn’t fully downloaded, and now you have a bad cache, did you run conda clean --all before creating the environment again? Perhaps the ClobberWarning is just unrelated fallout and will go away if we get a complete package downloaded.

1 Like

I tried conda clean --all and I am still getting all of the errors.

which python (before qiime2 activation):
/home/christian/miniconda3/bin/python

which python (after qiime2 activation)
/home/christian/miniconda3/envs/qiime2-2018.2/bin/python

I've attached the outputs of the other commands you requested, as well the full installation error output.
conda_info.txt (5.2 KB)
env_before_qiime2_activation.txt (7.1 KB)
conda_list_before_qiime2_activation.txt (6.8 KB)
env_after_qiime2_activation.txt (7.4 KB)
conda_list_after_qiime2_activation.txt (17.1 KB)
full_qiime2-2018.4_installation_error.txt (137.0 KB)

Thanks,
Christian

1 Like

Hey @ChristianEdwardson,

Sorry for taking so long to get back to this. Your conda looks to be up-to-date, so that’s good.

From your first file, I see this:

PATH: /home/christian/miniconda3/bin:/home/christian/MyTaxa-master:/home/christian/.rbenv/plugins/ruby-build/bin:/home/christian/.rbenv/shims:/home/christian/.rbenv/bin:/home/christian/miniconda3/bin:/home/christian/biobakery-metaphlan2-5ea2bdea8b78:/home/christian/biobakery-metaphlan2-5ea2bdea8b78/utils/:/home/christian/pipits/bin:/usr/lib/:/home/christian/qiime_software/chimeraslayer-4.29.2010-release/ChimeraSlayer:/home/christian/qiime_software/chimeraslayer-4.29.2010-release/NAST-iEr:/home/christian/qiime_software/cytoscape-2.7.0-release/.:/home/christian/qiime_software/rdpclassifier-2.2-release/.:/home/christian/qiime_software/muscle-3.8.31-release/.:/home/christian/qiime_software/ea-utils-1.1.2-537-release/.:/home/christian/qiime_software/blast-2.2.22-release/bin:/home/christian/qiime_software/qiime-galaxy-0.0.1-repository-de3646d3/scripts:/home/christian/qiime_software/ampliconnoise-1.27-release/Scripts:/home/christian/qiime_software/ampliconnoise-1.27-release/bin:/home/christian/qiime_software/raxml-7.3.0-release/.:/home/christian/qiime_software/drisee-1.2-release/.:/home/christian/qiime_software/clearcut-1.0.9-release/.:/home/christian/qiime_software/cdbtools-10.11.2010-release/.:/home/christian/qiime_software/pprospector-1.0.1-release/bin:/home/christian/qiime_software/rtax-0.984-release/.:/home/christian/qiime_software/sourcetracker-1.0.0-release/.:/home/christian/qiime_software/tax2tree-1.0-release/bin:/home/christian/qiime_software/blat-34-release/.:/home/christian/bin:/home/christian/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/home/christian/bbmap_37.66:/home/christian/ngsutils-ngsutils-0.5.9/bin:/home/christian/mothur:/home/christian/sratoolkit.2.8.1-2-ubuntu64/bin:/home/christian/SPAdes-3.11.1-Linux/bin:/home/christian/ncbi-blast-2.7.1+/bin:/home/christian/bowtie2-2.3.3.1-linux-x86_64:/home/christian/MUMmer3.23:/home/christian/arb/bin:/home/christian/edirect:/home/christian/centrifuge/centrifuge:/home/christian/eggnog-mapper-1.0.3:/home/christian/apache-maven-3.5.2/bin:/home/christian/ESOM/bin:/home/christian/prokka/bin:/home/christian/barrnap-0.8/bin:/home/christian/FastTree:/home/christian/phylophlan:/home/christian/phyloskeleton::/home/christian/phyloskeleton/utils:/home/christian/miniconda3/bin
PYTHONPATH: /home/christian/qiime_software/qiime-galaxy-0.0.1-repository-de3646d3/lib/:/home/christian/qiime_software/pprospector-1.0.1-release/lib/python2.7/site-packages:/home/christian/qiime_software/tax2tree-1.0-release/lib/python2.7/site-packages:

It looks like you have a PYTHONPATH set as well as a lot of other things in your PATH. While I don’t know that this is the issue, it can cause trouble sometimes. Since you have QIIME 2018.2, I’m not sure why it would suddenly be an issue.

Your root environment is a bit polluted with other packages, but once again, nothing stands out as really being a problem.

The number of clobberwarnings from your install output is pretty impressive.

Let’s try a few other things, because other than the ENV variables potentially being an issue, nothing else seems terribly out of place.

I guess the first step is to entirely rule out the path situation.

In a new terminal, run:

export PATH='/home/christian/miniconda3/bin:/home/christian/bin:/home/christian/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin'
unset PYTHONPATH

That will make things more “normal” for the remainder of that terminal session.

Then try reinstalling.

If you get the same issue, we’ll try another more extreme thing:

rm -r /home/christian/miniconda3/pkgs

This will entirely remove the conda package cache (conda will remake the directory).

Then try reinstalling again.

2 Likes

So…the ‘extreme’ option worked. I still got a bunch of ClobberWarnings (see below)…but it’s installed and working. Thanks!

e.g.:
ClobberWarning: This transaction has incompatible packages due to a shared path.
packages: conda-forge::entrypoints-0.2.3-py35_1, conda-forge::testpath-0.3.1-py35_0, conda-forge::traitlets-4.3.2-py35_0, conda-forge::nbformat-4.4.0-py35_0, conda-forge::pip-9.0.3-py35_0
path: ‘lib/python3.5/site-packages/pip/_vendor/packaging/pycache/requirements.cpython-35.pyc’

and
e.g:
ClobberWarning: Conda was asked to clobber an existing path.
source path: /home/christian/miniconda3/pkgs/lockfile-0.12.2-py35_0/lib/python3.5/pycache/glob.cpython-35.pyc
target path: /home/christian/miniconda3/envs/qiime2-2018.4/lib/python3.5/pycache/glob.cpython-35.pyc

Following up one more time on this…because of the ‘extreme’ option, QIIME1 wasn’t working (wanted it to demultiplex with golay_12 error correction) thus I had to reinstall it, using conda. I wasn’t able to get the conda installation of QIIME1 to work until I ran the following commands to change conda channel priorities, in this order (makes bioconda top priority).

conda config --add channels conda-forge
conda config --add channels defaults
conda config --add channels r
conda config --add channels bioconda

This may not be relevant to QIIME2, but I wanted to leave it here just in case someone else had issues with installation with conda.

2 Likes

You can also add flags to a command like so:
conda install -c conda-forge -c defaults -c r -c bioconda <conda-package-to-install>

Updating your global config will cause all future invocations to use that order (although that’s not a bad order to have!).

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.