Qiime2-2018.2 environemnt activation failed

Hi,

I’ve installed qiime2-2018.2 environment on Linux using miniconda3.
The installation was ok, and qime2-2018.2 is in the list of environments.
When I try to activate the environment I get:

<11|0>[email protected]:~% source activate qiime2-2018.2
_CONDA_ROOT=/cs/icore/naamasht/bin/miniconda3: Command not found.
Badly placed ()'s.

I tries looking into this, but couldn’t figure out what’s the problem or how to fix it.
Help?

Thanks!

Good afternoon,

Do you know if you are using the bash or csh? Looks like you could try activating your environment like this:

source activate.csh qiime2-2018.2

Let me know if that works!
Colin

1 Like

Thanks, but it doesn’t work…
no such file or directory

Hi @naamasht,

What does the following print:

echo $0

and

echo $SHELL

Also, there’s a new way of activating conda environments we could try.
If you ran:

conda activate qiime2-2018.2

It is probably going to print out a bunch of instructions like this:

CommandNotFoundError: Your shell has not been properly configured to use 'conda activate'.
If your shell is Bash or a Bourne variant, enable conda for the current user with

    $ <redacted>

or, for all users, enable conda with

    $ <redacted>

The options above will permanently enable the 'conda' command, but they do NOT
put conda's base (root) environment on PATH.  To do so, run

    $ <redacted>

in your terminal, or to put the base environment on PATH permanently, run

    $ <redacted>

Previous to conda 4.4, the recommended way to activate conda was to modify PATH in
your ~/.bashrc file.  You should manually remove the line that looks like

    export PATH="/opt/Miniconda3/bin:$PATH"

^^^ The above line should NO LONGER be in your ~/.bashrc file! ^^^

If you follow the instructions that are printed to your terminal it may work better, and you would then use conda activate instead of source activate.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.