QIIME2-2017.5 Installation Problem

I have attempted to install qiime2-2017.5, following the instruction guide, and while it creates the environment it does not download the qiime packages. Once in the environment any command comes back as command not found. What do I need to do to install the packages? I have deleted the environment and attempted to reinstall but the same problem arises.

Hi @Kitkat14! Can you please post the exact commands you’re running to install QIIME 2 2017.5, as well as the output produced by the commands? Also, what platform are you installing QIIME 2 on (Linux or macOS)?

Hello @jairideout!

I am on macOS. To install it I am running:

conda create -n qiime2-2017.5 --file https://data.qiime2.org/distro/core/qiime2-2017.5-conda-osx-64.txt

So once it installs if I run conda list this is what I receive (nothing appears):

# packages in environment at /Users/bioresearch/miniconda3/envs/qiime2-2017.5:

Then when I do a command for example this happens:

(qiime2-2017.5) Academics-Mac-mini:~ bioresearch$ qiime --help
-bash: qiime: command not found

Can you try removing your existing qiime2-2017.5 environment and creating a new one? To do that:

  1. Open a new terminal.
  2. Make sure you’re not in a conda environment:
    source deactivate
  3. Remove your existing environment:
    conda env remove -n qiime2-2017.5
  4. Install QIIME 2:
    conda create -n qiime2-2017.5 --file https://data.qiime2.org/distro/core/qiime2-2017.5-conda-osx-64.txt
  5. Activate the new environment:
    source activate qiime2-2017.5
  6. Test installation:

If these steps don’t work for you, can you please send the complete output generated by step 4?

1 Like

Here is the output generated by step 4:
Academics-Mac-mini:~ bioresearch$ conda create -n qiime2-2017.5 --file https://data.qiime2.org/distro/core/qiime2-2017.5-conda-osx-64.txt
ERROR conda.core.link:_execute_actions(337): An error occurred while installing package ‘defaults::qt-5.6.2-2’.
CondaError: Cannot link a source that does not exist. /Users/bioresearch/miniconda3/pkgs/qt-5.6.2-2/lib/fonts/DejaVuSans-Bold.ttf
Attempting to roll back.

CondaError: Cannot link a source that does not exist. /Users/bioresearch/miniconda3/pkgs/qt-5.6.2-2/lib/fonts/DejaVuSans-Bold.ttf

Hey @Kitkat14,

It looks like you ran into an older bug with conda. You are probably just running an old version, so you can run:

conda update conda

and try again. Hopefully that fixes it!

If it doesn’t could you provide the version? (after updating):

conda --version

After updating I have conda 4.3.21.
I once again received the same error message when attempting to install qiime.

Hmm, perhaps something happened to conda's cache. Could you run conda clean -y --all? That should remove any cached packages like /Users/bioresearch/miniconda3/pkgs/qt-5.6.2-2/ which should stop conda from trying to link them for the new environment.


Thank you! That worked and I’ve gotten qiime installed. Thank you again!:grin:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.