qiime tools import

Hi everyone,

when I run the qiime tools import with the different parameters >>> qiime tools import --type EMPPairedEndSequences --input-path emp-paired-end-sequences --output-path emp-paired-end-sequences.qza<<<<

I have this error message >>>>> There was a problem importing emp-paired-end-sequences:
emp-paired-end-sequences/reverse.fastq.gz is not a(n) FastqGzFormat file:
File is uncompressed.

Can someone help me zith this issue.

Thank you.


Helo Manil,

Just like the error says, Qiime expects your files to be in the FastqGzFormat.

Can you post a few of the file names from the emp-paired-end-sequences directory?


Following up on @colinbrislawn’s suggestion here - it sounds like you might not have gzipped your files, but rather renamed them to the extensions .fastq.gz. How about you try something like this:

ls my-raw-seqs/
  barcode-reads.fastq  forward-reads.fastq   reverse-reads.fastq
mkdir emp-import
cp my-raw-seqs/barcode-reads.fastq emp-import/barcodes.fastq
cp my-raw-seqs/forward-reads.fastq emp-import/forward.fastq
cp my-raw-seqs/reverse-reads.fastq emp-import/reverse.fastq
cd emp-import
gzip barcodes.fastq
gzip forward.fastq
gzip reverse.fastq

You will need to update that a bit to match your file names, etc, but that should hopefully give you the general idea. If you get stuck, you know where to find us! :t_rex:

1 Like

Hello @colinbrislawn and @thermokarst,

I was just following the ACATAMA-soils tutorial so I used the wget command to have the set of data provided in the tutorial, in the emp-paired-end-sequences directory i have three files : barcodes.fastq.gz forward.fastq.gz and reverse.fastq.gz.

At the end I have just removed the extention .gz and used the gzip command, now it works !!! a bit strange

Thank you for your response


1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.