Qiime tools import not working

Dear Admin

I am using again my Qiime2 after about 1 month. Earlier It was working fine.
Between (During this time, once I tried to install BowTie using this terminal)

Now whenI put "qiime tools import"
qiime tools import
--type EMPPairedEndSequences
--input-path emp-paired-end-sequences
--output-path emp-paired-end-sequences.qza

It says bash: qiime: command not found

See two top lines in the image, which I think were not here before.


Hello @drmusk! It looks like your QIIME 2 environment isn’t being loaded when you launch a new terminal (automatic environment loading is a convenience that we have added to the QIIME 2 Virtual Machines, that way you don’t have to manually run source activate $NAME-OF-MY-Q2-ENV). Judging from your screenshot, it looks like your .bashrc file was edited (maybe by you, maybe by some other piece of software that you have installed in this VM). I can tell because the first two lines in the screenshot show errors that come from typos or invalid commands/config in that .bashrc file. Because the .bashrc is invalid, it isn’t loading correctly, which is preventing the QIIME 2 environment from being loaded by default.

You have a few options:

  • Upgrade QIIME 2 VMs — it looks like you are using 2017.7, which is pretty old and unsupported. A new VM will work out-of-the-box, and you can just remount your analysis directory and pick up where you left off.
  • Fix your .bashrc: we can’t help you with this because this is an unsupported QIIME 2 build, but you could try and fix up your .bashrc (maybe you made those edits yourself? if so that might be easier to track down the issue).
  • Manually activate your QIIME 2 environment each time you launch a new terminal: source activate qiime2-2017.7

Good luck and thanks for posting!

Dear Dr Dillon
Thanks for a comprehensive reply.
As I told you that I tried to install bowtie2 using this terminal. So might I have messed-up stuff.
I will prefer to go with your option 1. Updating the Qiime2.10.
1 more silly question. As you suggested earlier, you may not be helpful in that but still I am asking it

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.