QIIME tools import files in subdirectories

Dear Forum:
I’ve searched to forum but can’t find an aswer. I’v reviewed the Forum Glossary. I’m running QIIME 2 version 2019.10.0 installed via conda.

I’m trying to import PE sequence files. Each sample has it’s own directory with the forward and reverse fastq files in it but qiime tools import doesn’t seem built to handle this situation. When I run:

qiime tools import
–type ‘SampleData[PairedEndSequencesWithQuality]’
–input-path ./among_islands
–input-format CasavaOneEightSingleLanePerSampleDirFmt
–output-path among_islands_demux-paired-end.qza

I get

There was a problem importing ./among_islands:
among_islands is not a(n) CasavaOneEightSingleLanePerSampleDirFmt:
Contains a subdirectory: T65_L001-ds.c51d84253e4044bf8091264d78d61d26

the subdirectory contains the two fastq files.

  1. Is there a specific format I can specify to handle this other than CasavaOneEightSingleLanePerSampleDirFmt? or
  2. Is there something like a wildcard character I can use? or
  3. Anybody have a LINUX script that will extract the two fastq files from each of the 160 subdirectories and cd them to the parent directory?

Thanks,
Steve

Sorry, I mean cp them, not cd them.

@skimble, thanks for asking such a clear qeustion. Have you looked through the importing tutorial? Casava requires a specific directory structure. Manifeset format imports are more flexible, allowing you to specify filepaths. I suspect that approach will suit your needs.

@ChrisKeefe, groovy, that solved it! I shoulda seen it but (and I am NOT complaining) there is a lot of QIIME documentation! Thanks!

4 Likes