Qiime Studio installation

I am trying to install the qiime2 studio, but when I run the install command, I get the following:

(qiime2) DENR-MNS-49F9VN:q2studio-2017.10.0 genlab$ pip install .
Processing /Users/genlab/q2studio-2017.10.0
dyld: lazy symbol binding failed: Symbol not found: _fdopendir$INODE64
  Referenced from: /Users/genlab/miniconda3/envs/qiime2/lib/libpython3.5m.dylib
  Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: _fdopendir$INODE64
  Referenced from: /Users/genlab/miniconda3/envs/qiime2/lib/libpython3.5m.dylib
  Expected in: /usr/lib/libSystem.B.dylib

Trace/BPT trap: 5

I also got this response when I tried to import the data for the moving pictures tutorial. I tried using both miniconda2 and miniconda3 in case there was a bug in one of those. Also searched for _fdopendir$INODE64 but can’t find it anywhere in my system.


Hi @Heather_E!

We normally see these Symbol not found type errors when you accidentally install the Mac build on a Linux system or the Linux build on a Mac system. I would recommend removing your QIIME 2 conda environment and reinstalling, ensuring that you select the right platform (judging from your filepaths, it looks like you are on a Mac…).

You can run the following to uninstall your environment:

conda env remove -n qiime2
conda clean -y --all

Then, follow the installation instructions on the docs site! Good luck and keep us posted! :t_rex:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.