QIIME" not working on MacOS Catalina

Hello.

I am a QIIME2 user. I am using a computer with MacOs Catalina 10.15.7. I installed anaconda3 and QIIME2 according to https://qiime2.org. However, I cannot use QIIME2 because I cannot work the command like quine --help.

I may be able to work only qiime2-tiny-2023.9 but on the others not work.
Let me explain my problem below.

・Amplicon distribution
(base) seita@SEITA-no-MacBook-Air ~ % conda activate qiime2-amplicon-2023.9
(qiime2-amplicon-2023.9) seita@SEITA-no-MacBook-Air ~ % qiime --help
zsh: command not found: qiime
(qiime2-amplicon-2023.9) seita@SEITA-no-MacBook-Air ~ % conda deactivate

・Shotgun distribution
(base) seita@SEITA-no-MacBook-Air ~ % conda activate qiime2-shotgun-2023.9
(qiime2-shotgun-2023.9) seita@SEITA-no-MacBook-Air ~ % qiime --help
zsh: command not found: qiime
(qiime2-shotgun-2023.9) seita@SEITA-no-MacBook-Air ~ % conda deactivate

・Tiny distribution
(base) seita@SEITA-no-MacBook-Air ~ % conda activate qiime2-tiny-2023.9
(qiime2-tiny-2023.9) seita@SEITA-no-MacBook-Air ~ % qiime --help
Usage: qiime [OPTIONS] COMMAND [ARGS]...

QIIME 2 command-line interface (q2cli)

To get help with QIIME 2, visit https://qiime2.org.

To enable tab completion in Bash, run the following command or add it to
your .bashrc/.bash_profile:

  source tab-qiime

To enable tab completion in ZSH, run the following commands or add them to
your .zshrc:

  autoload -Uz compinit && compinit
  autoload bashcompinit && bashcompinit
  source tab-qiime

Options:
--version Show the version and exit.
--help Show this message and exit.

Commands:
info Display information about current deployment.
tools Tools for working with QIIME 2 files.
dev Utilities for developers and advanced users.
(qiime2-tiny-2023.9) seita@SEITA-no-MacBook-Air ~ % conda deactivate

Can anybody help? Thank you very much!

Hello @seita,

Can you run echo $PATH with the environment activated?

1 Like

Hello @colinvwood ,
I ran it with the qiime2-amplicon-2023.9 environment activated.
I show you the result below.

(qiime2-amplicon-2023.9) seita@SEITA-no-MacBook-Air ~ % echo $PATH
/Users/seita/anaconda3/envs/qiime2-amplicon-2023.9/bin:/Users/seita/anaconda3/condabin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin

Thank you very much for your kind support!

Hello @seita,

And what does ls /Users/seita/anaconda3/envs/qiime2-amplicon-2023.9/bin | grep qiime return (with the environment activated)? What about when your run the deblur command with your environment activated?

Hello @colinvwood ,

I am sorry for late to reply your kind message.

I show you the result below.

(qiime2-amplicon-2023.9) seita@SEITA-no-Air ~ % ls /Users/seita/anaconda3/envs/qiime2-amplicon-2023.9/bin | grep qiime

ls: no such file or directory: Users/seita/anaconda3/envs/qiime2-amplicon-2023.9/bin

When I ran the command on the above, I was told that there is no such file or directly, so I tried to move the file of "qiime2-amplicon-2023.9" and run "ls", the answer was below.

(qiime2-amplicon-2023.9) seita@SEITA-no-Air qiime2-amplicon-2023.9 % ls

conda-meta etc lib share var

I think there does not exist the file of "bin" in the "qiime2-amplicon-2023.9".

Next, I ran deblur command with my environment activated. The result is below.

(qiime2-amplicon-2023.9) seita@SEITA-no-Air ~ % deblur

zsh: command not found: deblur

Thank you very much for your great support!

Hello @seita,

Could you try recreating the environment from scratch?