Qiime longitudinal linear-mixed-effects issue

I’m attempting to use the qiime longitudinal linear-mixed-effects on Bray Curtis data. My command is as follows:
qiime longitudinal linear-mixed-effects --m-metadata-file sample-metadata.txt --m-metadata-file core-metrics-results/bray_curtis_pcoa_results.qza --p-metric Axis 1 --p-group-columns MOD,Sex,Group --p-state-column Age --p-individual-id-column BabyID --o-visualization linear-mixed-effects.qzv

I get an error that says, Error: Got unexpected extra argument (1)

I have ran the same command with --m-metadata-file core-metrics-results/shannon_vector.qza and p-metric shannon and it worked.

At first I thought it was the metric but I used qiime metadata tabulate to confirm Axis 1.
Any suggestions?

Looks like it is indeed the metric. Try encapsulating it with single quotes. E.g., ‘Axis 1’. (otherwise the “1” is being interpreted as a separate argument!)

Let me know if that helps!

1 Like

Encapsulating ‘Axis 1’ gives me a new error: Plugin error from longitudinal: invalid syntax (, line 1) Debug info has been saved to /tmp/qiime2-q2cli-err-lrnhl6z7.log

I also tried exporting the bray_curtis_pcoa_results.qza to see if I could rename the Axis 1 but that didn’t work…

Any other suggestions?
Thanks!

Could you please post the contents of /tmp/qiime2-q2cli-err-lrnhl6z7.log (or if that does not exist any more, re-run the command with the --verbose flag and post the full error here)?

That should work if you export/rename/import properly. But let’s ignore that for now — there should be a better way to address this!

Could you share the following files here? (you can send to me in a DM if you do not wish to post these publicly).
sample-metadata.txt
bray_curtis_pcoa_results.qza

Thanks!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.