Qiime installation on virtualbox - memory error


I’m planning to use qiime for the first time. Since my machine has windows OS, I first installed a virtual box - (Oracle VM Virtual Box version 5.2.18 r124319).

Then I downloaded qiime on my machine (not the virtual machine) - qiime 2 core 2018.8.

As given in the instructions, I then double clicked on the ovf file, and began import using the default settings. This gives me an error - VERR_DISK_FULL (Result Code: VBOX_E_FILE_ERROR (0x80BB0004)

So I tried two things:

  1. Went to the settings of the virtualbox and increased the base memory to ~5GB in System.
  2. Before trying to import, I decreased the memory requirement from ~2GB to ~1GB of the RAM in the Qiime ovf file.

Neither of these options works - I’m still getting the same error. What must I do?

Other maybe relevant stuff:
At first, I didn’t realize that I had to do this importing stuff - so on the virtual machine, I tried to install qiime using something like sudo apt get. So there is qiime (or a part of it) installed on the virtual machine already. But when I tried to run the paired end read analysis commands given here , I got an error: \usr\lib\qiime\bin\tools.py not found. So I thought maybe my qiime installation was wrong and decided to do it the way suggested here

I would appreciate any help!

Hello @kmz!

I think this error has to do with your available disk space, not your RAM (memory). It looks like you have run out of disk space.

Hello @thermokarst,

Thanks for your response. Do you mean the disk space on my machine or the virtual machine? The virtual machine was just installed and apart from my data files, there is nothing else on it. My machine has at least 26GB free.

That error looks like your host system has run out of disk space.

Got it! Thanks. I had to free up space on the C drive.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.