Qiime --help throws error after installing qiime2 on Mac

I just installed Miniconda2 and then ran

conda create -n qiime2-2017.10 --file https://data.qiime2.org/distro/core/qiime2-2017.10-conda-osx-64.txt

to install Qiime2 on my Mac.

However, when I run

source activate qiime2-2017.10

and then

qiime --help

i get the following error:

(qiime2-2017.10) host14-113:~ polarmicrobes$ qiime --help
QIIME is caching your current deployment for improved performance. This may take a few moments and should only happen once per deployment.
Traceback (most recent call last):
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/bin/qiime", line 6, in <module>
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/click/core.py", line 722, in __call__
    return self.main(*args, **kwargs)
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/click/core.py", line 696, in main
    with self.make_context(prog_name, args, **extra) as ctx:
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/click/core.py", line 621, in make_context
    self.parse_args(ctx, args)
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/click/core.py", line 1018, in parse_args
    rest = Command.parse_args(self, ctx, args)
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/click/core.py", line 880, in parse_args
    value, args = param.handle_parse_result(ctx, opts, args)
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/click/core.py", line 1404, in handle_parse_result
    self.callback, ctx, self, value)
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/click/core.py", line 78, in invoke_param_callback
    return callback(ctx, param, value)
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/click/core.py", line 809, in show_help
    echo(ctx.get_help(), color=ctx.color)
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/click/core.py", line 496, in get_help
    return self.command.get_help(self)
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/click/core.py", line 830, in get_help
    self.format_help(ctx, formatter)
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/click/core.py", line 845, in format_help
    self.format_options(ctx, formatter)
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/click/core.py", line 956, in format_options
    self.format_commands(ctx, formatter)
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/click/core.py", line 1000, in format_commands
    for subcommand in self.list_commands(ctx):
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/q2cli/commands.py", line 69, in list_commands
    plugins = sorted(self._plugin_lookup)
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/q2cli/commands.py", line 53, in _plugin_lookup
    import q2cli.cache
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/q2cli/cache.py", line 302, in <module>
    CACHE = DeploymentCache()
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/q2cli/cache.py", line 61, in __init__
    self._state = self._get_cached_state(refresh=refresh)
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/q2cli/cache.py", line 107, in _get_cached_state
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/q2cli/cache.py", line 200, in _cache_current_state
    state = self._get_current_state()
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/q2cli/cache.py", line 232, in _get_current_state
    import qiime2.sdk
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/qiime2/__init__.py", line 10, in <module>
    from qiime2.metadata import Metadata, MetadataCategory
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/qiime2/metadata.py", line 15, in <module>
    import pandas as pd
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/pandas/__init__.py", line 19, in <module>
    "Missing required dependencies {0}".format(missing_dependencies))
ImportError: Missing required dependencies ['numpy']

However, I can find various numpy files in the Miniconda qiime2 environment, so I am not quite sure why it reporting this dependency missing.

Any help would be much appreciated. Thanks!

Hi @ctekellogg! That is weird! It sounds like something went sour with the installation — I would suggest removing the conda env, and trying again. Please see this post for details on how to do that (you will need to update the commands to reference 2017.10)

Keep us posted and good luck! :t_rex:

Thanks @thermokarst. Prior to posting I had already run:

conda env remove -n qiime2-2017.10
conda clean -y --all

but had forgotten to mention that. I did not rerun

conda update conda

I ran all three steps together and still have the same problem. When I ran

conda env remove -n qiime2-2017.10

I did get the following error

WARNING conda.core.link:run_script(516): pre-unlink script failed for package conda-forge::widgetsnbextension-3.0.6-py35_0
consider notifying the package maintainer

but it still seems like it managed to fully remove the qiime2 environment (qiime2 did not open when typed source activate qiime2 to double check) before i recreated it using the steps provided here https://docs.qiime2.org/2017.10/install/native/#install-miniconda.


Thanks for the info, @ctekellogg!

It isn’t clear to me in your reply if reinstalling worked or not, so if it didn’t, can you please run the following commands and follow up here with their results?

  1. Before activating your qiime2 environment:
$ uname -a
$ alias python
$ ls $HOME/.local/lib
$ conda info -a 
  1. After activating your conda environment:
$ which python
$ python --version
$ which qiime
$ conda list
$ python -c "import numpy; print(numpy.__version__)"


Hi @thermokarst,

The reinstalling did NOT work. Sorry for the confusion.

I'm attaching the results of the commands you sent.

qiime2_troubleshooting.txt (19.4 KB)

Thank you for your help with this!

From your attached log:

(qiime2-2017.10) Colleen-Kelloggs-MacBook-Pro:~ polarmicrobes$ python -c "import numpy; print(numpy.__version__)"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/numpy/__init__.py", line 142, in <module>
    from . import add_newdocs
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/numpy/add_newdocs.py", line 13, in <module>
    from numpy.lib import add_newdoc
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/numpy/lib/__init__.py", line 8, in <module>
    from .type_check import *
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/numpy/lib/type_check.py", line 11, in <module>
    import numpy.core.numeric as _nx
  File "/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/numpy/core/__init__.py", line 34, in <module>
    from . import umath
ImportError: dlopen(/Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/numpy/core/umath.cpython-35m-darwin.so, 2): Symbol not found: ___sincos_stret
  Referenced from: /Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/numpy/core/umath.cpython-35m-darwin.so
  Expected in: /usr/lib/libSystem.B.dylib
 in /Users/polarmicrobes/miniconda2/envs/qiime2-2017.10/lib/python3.5/site-packages/numpy/core/umath.cpython-35m-darwin.so

Of particular interest is this line:

2): Symbol not found: ___sincos_stret

I think we found the culprit! It looks like you are running Mac OS X 10.8 (Mountain Lion), which is a very old version of Mac OS X (relatively speaking!). Apparently there are issues with running numpy on that version of OS X. I am not sure what version of Mac OS X the conda-supplied numpy builds are built against (one of us will follow-up here if we find that information). Moving forward, one of the following options should work for you:

  • Upgrade your Mac to a recent version of macOS/OS X (High Sierra just came out, that might be a good place to start, if your hardware supports it)
  • Use a QIIME 2 Virtual Machine. The AWS and Virtualbox options should work well for you, but, the Docker VM is probably not a great idea, given how old your OS X is — I suspect it will be more trouble than it is worth.

Keep us posted! :t_rex:

EDIT: I opened an issue on our issue tracker.


I was wondering if that might be the problem. I was holding off on updating for a variety of programs that did not seem to like newer OS’s. I don’t use them as much any more so maybe I should pull the trigger and update. I’ll let you know if that resolves the issue.

Thank you!

1 Like

Yes, @thermokarst - that fixed it! All set to broaden my horizons from qiime1 to qiime2. Thank you!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.