qiime feature-table summarize error

Hello,

I have been trying to rerun demultiplexed samples obtained from our sequencing center. I have gotten to the point that I want to visualize my dada2 output, but am receiving an error with my metadata file. I ran a check on keemei and received an error because the sample ids provided had “_” instead of “-” (Example: Lisa001_0023-8-5-2015). I tried converting that character, and still have the same problem. I found a similar topic in the forum and made sure that my file was saved in UTF-8 format, but that didn’t help. Any insight would be helpful!

Thanks,
Patty

Error reveived:

There was an issue with loading the file Mapping_file_012820.csv as metadata:

Found unrecognized ID column name ‘\ufeffsample-id,barcode-sequence,Diet’ while searching for header. The first column name in the header defines the ID column, and must be one of these values:

Case-insensitive: ‘feature id’, ‘feature-id’, ‘featureid’, ‘id’, ‘sample id’, ‘sample-id’, ‘sampleid’

Case-sensitive: ‘#OTU ID’, ‘#OTUID’, ‘#Sample ID’, ‘#SampleID’, ‘sample_name’

There may be more errors present in the metadata file. To get a full report, sample/feature metadata files can be validated with Keemei: https://keemei.qiime2.org

Find details on QIIME 2 metadata requirements here: https://docs.qiime2.org/2018.11/tutorials/metadata/

Mapping_file_012820.csv (3.2 KB)

Hi!
Your metadata file in .csv format. You should convert it to .tsv format first

2 Likes

Hi @gondry2!

I just want to mention, QIIME 2 (and Keemei) don’t have special requirements for underscores (_) vs hyphens (-), what matters is that your Sample IDs match exactly between your demuxed sequences/feature table and your sample metadata.

As @timanix mentioned, this error is because you are using a CSV for metadata, rather than a TSV.

I think it might be helpful for you to spend some time reviewing the Metadata tutorial, this should help steer you in the right direction:

https://docs.qiime2.org/2019.10/tutorials/metadata/