qiime feature-classifier classify-sklearn only uses 1 cpu?

(Wolfgang Rumpf) #1

I’ve seen a few threads that talk about this sort of issue, but none of them seemed to answer my question…

I’m running qiime2.2018.11 on a 20-cpu system. When I execute this command:

qiime feature-classifier classify-sklearn
–i-classifier …/silva-132-99-nb-classifier.qza
–i-reads rep-seqs.qza
–o-classification taxonomy.qza
–p-n-jobs 20

Only 1 cpu is used. And that poor lone CPU is maxed out and would desperately love to play with his friends. Am I running the command incorrectly?

#2

Hi! Did you try to put --p-n-jobs equal to -1 (all happy CPUs) or -2 (all CPUs minus 1)?

(Nicholas Bokulich) #3

Hi @wolfgang.rumpf,
I suspect this may have more to do with the system you are running this on, and how many resources you are requesting, rather than QIIME 2. If you are running this on a server or compute cluster, you should discuss with the administrator to make sure you are requesting resources properly. If not, please let us know a little more about your system. q2-feature-classifier is definitely configured to use multiple cores!

(Wolfgang Rumpf) #4

I have tried the --p-n-jobs -1 setting to no avail. Resource request and allocation are “correct” (I use this system for many different types of applications), but that doesn’t mean that the system and QIIME2 are interacting properly. I’ll poke the admin and see if he can help!

1 Like