Qiime diversity core-metrics

Hi

Please assist, I ran this script qiime diversity core-metrics --i-phylogeny rooted-tree.qza --i-table table.qza --p-sampling-depth 100 --output-dir metrics
and I got this error Error: no such option: --i-phylogeny

Thank you for your assistance

Hi @kedi,

It looks like you are using diversity core-metrics which is meant for non-phylogenetic distances. You want to use diversity core-metrics-phylogenetic instead if you are going to providing a tree. I believe this was changed a few versions ago, so it is likely that if you had it working before in an older version, now you just need to make that minor adjustment.

2 Likes

Hi Mehrbod

Thanks for your response, I ran the script
qiime diversity core-metrics-phylogenetic --i-table table.qza --i-phylogeny rooted-tree.qza --p-sampling-depth 100 --m-metadata-file metadata.tsv --output-dir metrics and
the error i got isPlugin error from diversity:

β€œNone of [Index([β€˜C7’, β€˜B10’, β€˜C3’, β€˜A5’, β€˜D2’, β€˜B2’, β€˜H2’, β€˜H9’, β€˜A8B’, β€˜E10’, β€˜A2’,\n β€˜C5’, β€˜E6’, β€˜G4’, β€˜H3’, β€˜E11’, β€˜D8’, β€˜a3’, β€˜G10’, β€˜B7’, β€˜D12’, β€˜F2’,\n β€˜b3’, β€˜G6’, β€˜C9’, β€˜F4’, β€˜E7’, β€˜A12’, β€˜D5’, β€˜D3’, β€˜A9’, β€˜F6’, β€˜B12A’,\n β€˜D11’, β€˜H6’, β€˜C10’, β€˜B9’, β€˜A2B’, β€˜G7’, β€˜C6’, β€˜H5’, β€˜D7’, β€˜A11’],\n dtype=β€˜object’)] are in the [index]”

Debug info has been saved to /tmp/qiime2-q2cli-err-y5ohpvro.log. Please note that i passed my metadata under Keemei and it looked fine. Please assist!

Blockquote

1 Like

Hi @kedi,

The good news is that we passed the original error! This new error would suggest that qiime is failing to find the sample IDs it is looking for. From my own experience and a few other cases seen here, here are a few things to check for:
A) A wrong metadata file is being used by accident which has different sample-ids
B) The sample IDs in your metadata file do not match the sample-ids in your feature-table exactly. They have to be exact, case-sensitive and everything
C) Sometimes when converting from a program like excel to .tsv some funny unexpected formatting can carry over which can cause issues. Double check that the formatting is correct. I find it saving as .tsv from keemei is the best way to avoid this.

Start with those and let us know if the problem persists!
Good luck,
-Bod

kedimap.tsv (1.2 KB)

Hi

I still get the same error, my metadata was saved with an extension .tsv and I also double checked if my sample correspond those in the metadata file and they are the same. I have a attached my metadata so you can be able to help.

Thanks for your help

1 Like

Hi @kedi,

It looks as though the SampleIDs in your metadata file all end with β€œ.fasta” however the error message we received earlier indicates that qiime is expecting IDs from your feature table that don’t have that ending. for example β€˜C7’, β€˜B10’, β€˜C3’
Try removing all the .fasta from your metadata file and that should do the trick!

1 Like

metadata.tsv (1.7 KB

[email protected]

Thanks for your prompt response, I ran the script with the correct mapping file (see the attached) verified using keemei and saved with the extension .tsv on keemei. However i still get the same error

I ran qiime feature-table summarize --i-table table.qza --o-visualization table.qzv --m-sample-metadata-file metadata.tsv

and the error i got is Plugin error from feature-table:

"None of [Index(['b3', 'a3', 'A11', 'C5', 'G7', 'B12A', 'A5', 'F2', 'E7', 'G4', 'D12',\n 'D8', 'A8B', 'B2', 'G6', 'C7', 'A9', 'G10', 'H6', 'D11', 'F6', 'H9',\n 'D3', 'H2', 'C6', 'B9', 'F4', 'D2', 'C9', 'H3', 'E6', 'C3', 'D5', 'D7',\n 'A12', 'E10', 'C10', 'A2', 'B10', 'A2B', 'H5', 'B7', 'E11'],\n dtype='object')] are in the [index]"

Debug info has been saved to /tmp/qiime2-q2cli-err-_yf51wxl.log

Thanks in advance for your help

Hi @kedi! Did you see @Mehrbod_Estaki’s suggestion above? It looks like you just replaced the β€œ.fasta” extension with β€œ.fastq”, but what @Mehrbod_Estaki suggested is removing the extension entirely. This is necessary because ID matching in this version of QIIME 2 is performed on an exact match basis.

For example, you will want to rename A11.fastq to A11 in your sample metadata file.

Hope that helps, and thanks @Mehrbod_Estaki for the awesome suggestions! :t_rex:

2 Likes

Hi

Thanks a lot for the support, it ran!

kedi

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.