Qiime cutadapt demux-paired dual barecode in line

Hello everyone,

I got paired-end read with dual codebare in line. I used to demultiplexe my reads with 2 consecutives cutadapt rounds. It seems that qiime cutadapt demux-paired command can do this job. However, when I run it, it demultiplexes only the forward codebare. I don’t really know where i am worng. Is anyone can help me to fix it ?
Here an example of my manifest file (Metadata.csv):

sample-id      BC1                  BC2
sample1        ATCGGGAT     TGATTGAC
sample2        ATCGGGAT     GTTCACGA
sample3        TGGTCACA     TGATTGAC
sample4        TGGTCACA     GTTCACGA
sample5        CATCATGC      CCGACTTG

In the qza file I can see the files:

sample1-ATCGGGAT-R1.fastq.gz         sample1-ATCGGGAT-R2.fastq.gz  
sample3-TGGTCACA-R1.fastq.gz        sample3-TGGTCACA-R2.fastq.gz     
sample5-CATCATGC-R1.fastq.gz         sample5-CATCATGC-R2.fastq.gz

Here the command lines I wrote :

qiime tools import --type MultiplexedPairedEndBarcodeInSequence --input-path ./original_fastq --output-path ./original_fastq.qza
qiime cutadapt demux-paired --i-seqs ./original_fastq.qza --m-forward-barcodes-file ./Metadata.csv --m-forward-barcodes-column BC1 --m-reverse-barcodes-file ./Metadata.csv --m-reverse-barcodes-column BC2 --o-per-sample-sequences ./Demux/demux.qza --o-untrimmed-sequences ./Demux/untrimmed.qza

I thank you for your help !

Are you basing that on the filenames, or, by the nts present in the reads? If it is by the filenames, no need to worry there, the plugin is lazy and lists the forward barcode in both the forward and reverse files.

Thank you thermokarst for you answer. When I said it demultiplexe only the forward barecode I mean the BC1 (as the sample 2 and 4 seem to be mixed with the sample 1 and 3 respectively in my example). At least could you confirm that this kind of command can do this job in a single step? I have tried to put 2 seperated metadata file with only 1 column for each barecode (BC1 and BC2) but it doesn’t change anything.

Hi @Kap25, would you be able to send your data along, so that I can run the q2-cutadapt command above and debug locally? Feel free to DM me download links, if you don’t want to share publicly. Thank you!

Thanks for sharing your data, @Kap25! I had a look at this and ran things locally, cutadapt (and q2-cutadapt) appear to be working as expected here. Can you double check that your barcodes in your metadata file are correct? If you run the demux command with the --verbose flag you will see a very detailed demux report with information about what barcodes were found, and how often they were found. Take a peek at that and double-check your metadata file. Thanks! :qiime2:

Thank you for your answer. I will try again in the next days.