QIIME 2 VirtualBox instillation error bash: qiime: command not found


#1

Hello,
I am a very new user to QIIME. I could not find an answer for this particular problem on the form,
I just installed QIIME 2 Core - 2018.11 using VirtualBox 5.2.22 on Windows 10. I tried the basic command ‘qiime info’ in the terminal and I got the error ‘bash: qiime: command not found’. I followed the install tutorial for installing QIIME 2 with virtual machines, I do not understand what is going wrong, I have already tried re-extracting the zip file and re-importing the virtual machine but this does not work. I am not sure if this is an issue with instillation or something else.


(Jono Warren) #2

Maybe your conda environment isn’t active.

Try:

conda info --envs

if it looks like it is, (eg one of them says qiime) activate it by running:

conda activate name_of_environment

If all goes well try running qiime info again.


(Matthew Ryan Dillon) #3

Which account on the VM did you log into? You should be logged in as qiime - if not, please double-check the instructions for more details. Thanks!


#4

I was logged into the wrong account, a guest account. Logged into the qiime2 account and now qiime info is working without any issue.

Sorry for the trouble!