QIIME 2 has no plugin/command named 'metadata'.

I run the command bellow......

qiime metadata tabulate
--m-input-file fondue-output/metadata.qza
--o-visualization fondue-output/metadata.qzv

but it's showing error, (Error: QIIME 2 has no plugin/command named 'metadata'.)

I also run this command,
qiime info

and the result is,
System versions
Python version: 3.8.15
QIIME 2 release: 2022.8
QIIME 2 version: 2022.8.3
q2cli version: 2022.8.0

Installed plugins
fondue: 2022.4.0.dev0+12.g5afa120
types: 2022.8.0

Application config directory

Getting help
To get help with QIIME 2, visit https://qiime2.org

What to do now?

Hello @turtle, how did you install QIIME 2, and what environment did you install it in? It looks like the installation didn't go correctly. Official installation instructions can be found here

1 Like

I install it in conda environment. Do I neet to activate conda first? and then activate fondue?
or Do I need to uninstall qiime2 and reinstall again?

actually I was doing the fondue tutorial and this error is happening.

Hi @turtle, It's nice to see you are using q2-fondue. In the tutorial you are going through, there is a note there mentioning that to run qiime metadata tabulate you have to ensure that you have q2-metadata installed in your conda environment. You can do this with this command: conda install -c qiime2 q2-metadata. Let me know if this solves your error.

For background information: When installing q2-fondue according to the installation instructions, you are not installing the full QIIME2 ecosystem but only the packages needed to get q2-fondue running. q2-metadata is not part of this crucial set of packages. Therefore, we have to install it additionally if needed.


@adamova I didn't see the Note for installing metadata, thank you so much.
As I'm following the fondue tutorial there is Downstream analysis in QIIME 2. And it has "demux" & "dada2" command. I solved the same error for demux with "conda install -c qiime2 q2-demux" but the I think the same isn't working for "dada2".

Here I uploaded the image.

Hi @turtle,
To install q2-dada2 in this conda environment, you have to specify a few more channels. When running this with conda it is a lot slower than when using mamba install with the same parameters. Hence, I would suggest you run:
mamba install -c qiime2 -c conda-forge -c bioconda -c defaults q2-dada2. Let me know if this works.

We are planning to give more instructions on setting up the environment for running the complete q2-fondue tutorial soon :nerd_face:.

1 Like

I don't know. Is it not working? or I'm running the code wrong?

I just entered the folder where all the file is and run "conda activate fondue" then tried to run the suggested code "mamba install -c qiime2 -c conda-forge -c bioconda -c defaults q2-dada2".

but the following happens... :cry:

hm, what is the output of the commands conda env list and conda info --envs?

If this error persists maybe it is worth first removing the existing fondue environment and then creating a new one with:

  1. Deactivate current conda env & remove former fondue env:
conda deactivate
conda remove -n fondue --all -y
  1. Install & activate new basic fondue environment:
mamba create -y -n fondue \
   -c https://packages.qiime2.org/qiime2/2022.8/tested/ \
   -c conda-forge -c bioconda -c defaults \
   q2cli q2-fondue

conda activate fondue
  1. install the required dependencies for the tutorial
mamba install -c qiime2 -c conda-forge -c bioconda -c defaults q2-metadata q2-demux q2-dada2
qiime dev refresh-cache
1 Like

It helps, the code you suggest to install q2-dada2. But not in the process I mentioned above. I did the whole process from installing mamba and fondue from the stating code "conda install mamba -n base -c conda-forge" described in the "fondue tutorial". Can you please why I need to do the whole process?

and after the dada2 step I also failed to run the next command,

qiime feature-table summarize
--i-table fondue-output/dada2_table.qza
--m-sample-metadata-file fondue-output/metadata.qza
--o-visualization fondue-output/dada2_table.qzv

the error showing is....

Sure, I suggested to reinstall all the plugins because it seemed there was something broken in your former conda environment and with the information provided so far I could not pinpoint what was broken.

Yes, as before you would need to install feature-table in your conda environment with the command:
mamba install -c qiime2 q2-feature-table

1 Like

Thank you so much, @adamova :heart:

It really helped!!! I've been able to complete till the dada2 step.
But I just practiced this tutorial using these tsv files given in this tutorial. Now, if I want to do this for my own project where I have a list of project IDs in a csv or other format, how could I convert them into tsv format in qiime2? Like these provided in the tutorial folder of q2-fondue.....



And again, Thanks for all the suggestions above. :smiling_face_with_three_hearts:

Hi @turtle, I'm happy to hear that my suggestions were helpful.

QIIME2 is not the tool to use for converting csv (comma-separated value fields) to tsv (tab-separated value fields) files. You can:

  • either directly save the respective project IDs in a tsv instead of saving them in a csv file
  • you can do this transformation in a tool of your choice (e.g. Excel, TextEditor, R, Python - a simple "Tools to convert CSV to TSV" search in Google will give you more suggestions).

Good luck with your project!


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.