QIIME 2 has no plugin/command named 'feature-classifier'.

I'm trying to run the following command to use feature-classifier in fondue, but having the error mentioned in the screenshot.

conda install --override-channels -c defaults scikit-learn=0.21.2

Error image

Can anyone suggest that what's the problem here?

I also tried to install python2.7 in my ubuntu virtual OS. And this is shown as the install pythone version in my ubuntu virtual.

I guess this means that python version in not switched to 2.7. It still is in 3.9.12, Isn't it?
But how can I set python2.7 as my default python version?
Or, if I'm still missing the point of error what should I do to use this feature classifier? Please help...

Hi @turtle,

Is there a reason you're trying to specify the scikit-learn version for this environment?

In order to use q2-feature-classifier as well as q2-fondue, you should follow these instructions for installing q2-fondue within a QIIME 2 conda environment:

I would recommend starting fresh, and running conda clean --all if you've already tried installing these packages from scratch.

Cheers :lizard:

1 Like

Hi @lizgehret,
I tried a clean start and install q2-fondue in a QIIME environment and then I run the following code. Which shows another error.

   qiime feature-classifier classify-sklearn \
  --i-reads fondue-output/rep_seq.qza \
  --i-classifier silva-132-99-515-806-nb-classifier.qza \
  --o-classification fondue-output/taxonomy.qza

Error

Debug info saved in /tmp/qiime2-q2cli-err-p09a8wss.log is below

Hi @turtle,

Thanks for sharing those details! Here's what I suspect is going on - you had scikit-learn installed at a version of 0.21.2 when you ran q2-fondue to generate your rep_seq.qza file. Now you're attempting to run feature-classifier within your new QIIME 2 environment, which uses a newer version of scikit-learn (0.24.1). The short answer here is you'll need to re-run your q2-fondue command in your current environment to make sure you are using the same version of scikit learn for both commands.

Cheers :lizard:

1 Like

@lizgehret you mean I need to run the fondue command to recreate rep_seq.qza file?
I tried this but it doesn't work. Can you please be a little bit specific? like which code shoul I run or which command should I run in terminal?

Yes, you'll need to re-run the command you ran in q2-fondue to create the rep_seq.qza file in this new conda environment. I don't know what command you ran in q2-fondue to create that file, so I can't advise on that - but it should just be the same thing that you already ran the first time you created that artifact.

If this doesn't work, please include details with your exact command along with the error message you are receiving, otherwise it's hard to say where things are going sideways.

Cheers :lizard:

Dear @lizgehret,

First I run the following commands

conda install mamba -n base -c conda-forge
conda activate qiime2-2022.11
mamba install -y \
   -c https://packages.qiime2.org/qiime2/2022.11/tested/ \
   -c conda-forge -c bioconda -c defaults \
   q2-fondue
qiime dev refresh-cache
qiime fondue --help
vdb-config -i

And then I run the following command to creat the rep_seq.qza file,

qiime dada2 denoise-paired \
   --i-demultiplexed-seqs fondue-output/paired_reads.qza \
   --p-trunc-len-f 182 \
   --p-trunc-len-r 136 \
   --p-trim-left-f 19 \
   --p-trim-left-r 18 \
   --p-trunc-q 2 \
   --o-table fondue-output/dada2_table.qza \
   --o-representative-sequences fondue-output/rep_seq.qza \
   --o-denoising-stats fondue-output/dada2_stats.qza

Here is the files which I created by this command
dada2_table.qza (131.6 KB)
rep_seq.qza (136.4 KB)
dada2_table.qza (131.6 KB)

And then I run the following command to assign the taxonomy,

qiime feature-classifier classify-sklearn \
  --i-reads fondue-output/rep_seq.qza \
  --i-classifier silva-132-99-515-806-nb-classifier.qza \
  --o-classification fondue-output/taxonomy.qza

The classifier I used is, Silva 138 99% OTUs from 515F/806R region of sequences

But error showing after running the code is ,

I guess that's all you need to know to help me. :pleading_face:

@lizgehret or anyone can you guys help me out? :pleading_face:

Good morning,

Please be patient with us. Remember that this forum is a free service and we are all helping as best as we can.

It looks like there is still a version difference between the sklearn version installed, and what was used to make that silva classifier. Try downloading a matching silva classifier from here: Data resources — QIIME 2 2022.11.1 documentation

3 Likes

Thank you @lizgehret,
Sorry for my impatient :disappointed_relieved:
This works for the Greengenes 13_8 99% OTUs full-length sequences :green_heart:
Thank you....

1 Like