q2-SCNIC installation error

Thanks again for making everything clear. I’m going to use SCNIC for my feature table without any normalization. I’m installing SCNIC at the moment and unfortunately I had some errors while executing this command
conda install -c lozuponelab q2-SCNIC

The error is as follows:
Collecting package metadata (current_repodata.json): done

Solving environment: failed with initial frozen solve. Retrying with flexible solve.

Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.

Collecting package metadata (repodata.json): /

nsatisfiableError: The following specifications were found

to be incompatible with the existing python installation in your environment:


  • q2-scnic -> python=3.5

Your python: python=2.7

If python is on the left-most side of the chain, that’s the version you’ve asked for.

When python appears to the right, that indicates that the thing on the left is somehow

not available for the python version you are constrained to. Note that conda will not

change your python version to a different minor version unless you explicitly specify


The following specifications were found to be incompatible with each other:

Package bzip2 conflicts for:

python=2.7 -> bzip2[version=’>=1.0.6,<2.0a0’]

Package ncurses conflicts for:

python=2.7 -> ncurses[version=‘5.9.|6.0.|>=6.0,<7.0a0|>=6.1,<6.2.0a0|>=6.1,<7.0a0’]

Package zlib conflicts for:

python=2.7 -> zlib[version=‘1.2.|1.2.11.|1.2.11|1.2.8|>=1.2.11,<1.3.0a0’]

Package openssl conflicts for:

python=2.7 -> openssl[version=‘1.0.|1.0.,>=1.0.2l,<1.0.3a|>=1.0.2m,<1.0.3a|>=1.0.2n,<1.0.3a|>=1.0.2o,<1.0.3a|>=1.0.2p,<1.0.3a|>=1.1.1a,<1.1.2a|>=1.1.1b,<1.1.2a|>=1.1.1c,<1.1.2a|>=1.1.1d,<1.1.2a’]

Package sqlite conflicts for:

python=2.7 -> sqlite[version=‘3.13.|3.20.|>=3.20.1,<4.0a0|>=3.22.0,<4.0a0|>=3.23.1,<4.0a0|>=3.24.0,<4.0a0|>=3.25.2,<4.0a0|>=3.25.3,<4.0a0|>=3.26.0,<4.0a0|>=3.27.2,<4.0a0|>=3.28.0,<4.0a0|>=3.29.0,<4.0a0|>=3.30.0,<4.0a0’]

Package q2-types conflicts for:

q2-scnic -> q2-types[version=‘2018.11.|2018.8.|>=2016.6’]

Package libgcc-ng conflicts for:

python=2.7 -> libgcc-ng[version=’>=4.9|>=7.2.0|>=7.3.0’]

Package qiime2 conflicts for:

q2-scnic -> qiime2[version=‘2018.11.|2018.8.|>=2018.6’]

Package ca-certificates conflicts for:

python=2.7 -> ca-certificates

Package tk conflicts for:

python=2.7 -> tk[version=‘8.5.|8.6.|>=8.6.7,<8.7.0a0|>=8.6.8,<8.7.0a0|>=8.6.9,<8.7.0a0’]

Package libffi conflicts for:

python=2.7 -> libffi[version=‘3.2.*|>=3.2.1,<3.3.0a0|>=3.2.1,<4.0a0’]

Package pip conflicts for:

python=2.7 -> pip

Package libstdcxx-ng conflicts for:

python=2.7 -> libstdcxx-ng[version=’>=4.9|>=7.2.0|>=7.3.0’]

Package readline conflicts for:

python=2.7 -> readline[version=‘6.2.|7.|7.0.*|7.0|>=7.0,<8.0a0|>=8.0,<9.0a0’]

Package scnic conflicts for:

q2-scnic -> scnic[version=’>=0.5.3|>=0.6.*’]

Sorry to bother again!!!

Hi @uth,
I moved this post to this section as it was no longer related to the original inquiry.

Which version of Qiime2 are you using? I believe you may need to update your python and try again.


Thanks @Mehrbod_Estaki.

I’m using the latest version 2019.10. I found a solution on qiime forum; using
conda install -c lozuponelab -c conda-forge -c bioconda -c defaults --override-channels q2-SCNIC(posted below), but unfortunately it didn’t work as well.

Hi @uth,
I am pinging the SCNIC developer, @michael.shaffer — but unfortunately this is not the only SCNIC installation issue reported here and he has not been responsive the past few months.

Do you have the proper environment activated? QIIME 2 runs in python 3 but your error messages indicate that you are in a python 2.7 environment.


Thank you for the reply.

I have no trouble running qiime2 2019.10 version on my server. This is what I have in my system

python python2-config python3.4m python3.5m python3.6m python3m-config
python2 python3 python3.4m-config python3.5m-config python3.6m-config python-config
python2.7 python3.4 python3.5 python3.6 python3-config pythontex
python2.7-config python3.4-config python3.5-config python3.6-config python3m pythontex3

python --version on the terminal gives
Python 3.6.7

I cannot detect anything wrong. Sorry!