q2 scnic fails in calculating correlations

Dear All,
i recently installed SCNIC 2020.10+4.gf8566e7 on qiime2 version 2020.11.1
i tried to use the command qiime SCNIC calculate-correlations and it failed with the error:
Plugin error from SCNIC:

‘DataFrame’ object has no attribute ‘to_dense’

See above for debug info.

Now i checked the table i fed and it looks legit (asv table from dada2, i tried both rarefied and non)
I tried to run the example provided in https://github.com/lozuponelab/SCNIC/blob/master/tests/data/ but unfortunately i fail to import the biom table as i get the error:
fake_data.biom is not a(n) BIOMV210Format file
perhaps i am using the wrong version of qiime2/scnic?
any hint would be much appreciated!
thank you

Hi @Alfredo_Mari,

Welcome to the :qiime2: forum!

This is a version issue. There was a change between qiime2-2020.8 and qiime2-2020.11 in one of the underlying packages which changed behavior. That particular error should be solved if you go back to qiime2-2020.8 but SNIC may behave better with an earlier version.

Best,
Justine

Thank you Justine,
changing version made everything smoother and the data are outputted seemingly correctly.
One last question. I get in the log a recurrent warning:
“OpenBLAS Warning : Detect OpenMP Loop and this application may hang. Please rebuild the library with USE_OPENMP=1 option.”
Now this seems not to affect the results, although as it seems to be a problem with OpenMP i would think the parallelisation here is not optimal, you got any ideas how to fix it?
Thanks a lot in advance :slight_smile: