q2-fragment insertion error

I am following the q2-fragment-insertion tutorial.

qiime fragment-insertion sepp
–i-representative-sequences rep-seqs.qza
–i-reference-database sepp-refs-gg-13-8.qza
–o-tree insertion-tree.qza
–o-placements insertion-placements.qza

But there was a problem with the command:   (1/1?) no such option: --i-reference-database

in the script help, --i-representative-sequences doesn't exist!
Inputs:
  --i-representative-sequences ARTIFACT FeatureData[Sequence]
                       The sequences to insert                      [required]
  --i-reference-alignment ARTIFACT FeatureData[AlignedSequence]
                       The reference multiple nucleotide alignment used to
                       construct the reference phylogeny.           [optional]
  --i-reference-phylogeny ARTIFACT
    Phylogeny[Rooted]  The rooted reference phylogeny. Must be in sync with
                       reference-alignment, i.e. each tip name must have
                       exactly one corresponding record.            [optional]


following de pd-mice tutorial in qiime2's page the same error occurs
https://docs.qiime2.org/2019.10/tutorials/pd-mice/

thanks!

Hi @pufetin,

Ist he command you typed here the exact command you used where ever you’re running your code?

If so, please try

qiime fragment-insertion sepp \
--i-representative-sequences rep-seqs.qza \
--i-reference-database sepp-refs-gg-13-8.qza \
--o-tree insertion-tree.qza 
--o-placements insertion-placements.qza

The \ wraps the line in bash, which may be the source of your problem here.

thanks, but in practice, I write it all together,
qiime fragment-insertion sepp --i-representative-sequences rep-seqs.qza --i-reference-database sepp-refs-gg-13-8.qza --o-tree insertion-tree.qza --o-placements insertion-placements.qza

I separated it to be readable
“” aren’t the source

Hi @pufetin,

Okay. I’d suggest double checking your spaces then (only one between each flag and command). Then, have you tried copying and pasting the flag names exactly? I can’t find the spelling mistake, but I’m notoriously bad at finding spelling errors in my own work and other people’s. However, copying and pasting the flags gets me around that because then I don’t have to spell or see spelling mistakes in very long flags. (You could also try tab-complete here if you have it set up.)

Best,
Justine

in both tutorials use the option
–i-reference-database sepp-refs-gg-13-8.qza

but in the scrip help, this option (–i-reference-database) is not listed

Hi @pufetin,

Thanks for your patience with vacation.

The tutorial is up to date for qiime2-2019.10, but it looks like you’re working with an older version. So, try updating qiime2-2019.10 or following the documentation for your current version.

Best,
Justine

1 Like