pylogeny plugin error

Hello

I used raxml method commanlie (default parameter) for phylogenetic tree construction. This is the error I got

(qiime2-2019.7) [email protected]:~/miniconda2/envs/qiime2-2019.7/moraxellaca.taxaplot$ qiime phylogeny raxml-rapid-bootstrap --i-alignment aligned_rep-seqs-dada2.qza --p-n-threads 40 --o-tree bspt
Plugin error from phylogeny:

Command ‘[‘raxmlHPC-PTHREADS’, ‘-T 40’, ‘-f’, ‘a’, ‘-m’, ‘GTRGAMMA’, ‘-p’, ‘4939’, ‘-x’, ‘9213’, ‘-N’, ‘100’, ‘-s’, ‘/tmp/qiime2-archive-jkv9r7fq/45f18e3b-89c9-4170-b1fc-507d89fbb954/data/aligned-dna-sequences.fasta’, ‘-w’, ‘/tmp/tmpzzacudh5’, ‘-n’, ‘q2bootstrap’]’ died with <Signals.SIGTERM: 15>.

Debug info has been saved to /tmp/qiime2-q2cli-err-wr11ggg4.log

Could anyone tell me how to rectify this error?.

Thanking you in advance

Hello @Asha1,

Thanks for posting your full error message. Here’s our big clue:

SIGTERM means Signal Terminated, or “plugin canceled.” It looks like something shut down your plugin while it was running!

This has happened to me when I was running on a Linux cluster. Are you using a shared server or Linux cluster? Any other clues as to why a system administrator might cancel your Qiime plugin?

Colin

Hello,

I ran qiime feature-classifier classify-consensus-blast commandline with default parameter for my aligned_rep_seq_qza.

This is the error I got
(qiime2-2019.1) [email protected]:~/miniconda2/envs/qiime2-2019.1/v3-v4_region_result/sp/mo/moraxellaca.taxaplot$ qiime feature-classifier classify-consensus-blast --i-query rep-seqs-dada2.qza --i-reference-re
ads si_cs.qza --i-reference-taxonomy si_cs_txt.qza --o-classification blastclassification
Plugin error from feature-classifier:

Command ‘[‘blastn’, ‘-query’, ‘/tmp/qiime2-archive-r9wbuizi/ce425a22-beb2-4b17-979d-cd8b2b8487f0/data/dna-sequences.fasta’, ‘-evalue’, ‘0.001’, ‘-strand’, ‘both’, ‘-outfmt’, ‘7’, ‘-subject’, ‘/tmp/qiime2-archive-38knreqy/d5ce95
26-e2a9-4b53-8b72-a37a2c11da39/data/dna-sequences.fasta’, ‘-perc_identity’, ‘80.0’, ‘-qcov_hsp_perc’, ‘80.0’, ‘-max_target_seqs’, ‘10’, ‘-out’, ‘/tmp/tmpke479ble’]’ died with <Signals.SIGTERM: 15>.

Debug info has been saved to /tmp/qiime2-q2cli-err-rhv9n5f1.log

Could anyone tell me how to solve this error? . Thanking you in advance

Hello again @Asha1,

I’ve merged these two threads because while the plugin is different, the SIGTERM issue is the same.

Once we solve it, both these plugins should run.

Colin

Thank so much for your reply sir.
I am using shared server and no idea about how it got terminated.
Any ways, I will run qiime feature-classifier classify-consensus-blast analysis again, I will inform about this plugin problem to my system administrator also.

Ah ok! A shared server could explain this.

On the shared servers I’ve used, the system admins have rules about where you can run scripts and how much resources they can take. For example, on my current shared server, if a job uses too much ram / memory, it is automatically canceled and it shows an error like SIGTERM.

Talk to your HPC people who run the cluster, and see what they recommend!

Colin

1 Like

Hello sir,

Thank you for your response. qiime feature-classifier classify-consensus-blast analysis got over.

This is the command line I used
qiime feature-classifier classify-consensus-blast --i-query rep-seqs-dada2.qza --i-reference-reads si_cs.qza --i-reference-taxonomy si_cs_txt.qza --p-maxaccepts 2 --p-perc-identity 0.7 --p-query-cov 0.7 --o-classification P_blastclassification

I have one problem now sir, sample 6 to 5 has many hits. I want only 1 or 2 organism. Its really difficult for me to interpret the taxaplot. I tried changing maxaccepts and query coverage value form default to various value . Still, I am getting same taxa plot.

What should I do to represent only few hits in each sample?

Good morning,

Awesome!


Looks like your samples are very diverse! Congratulations!

If you want to simplify these plots, try changing the tax level from Level 7 (Species) to Level 2 (Phylum), like this:


:thinking:
It sounds like you expected to only have a few taxa in this sample, are are surprised to get so many. Is that correct? Are these samples supposed to have only two microbes in them?

Colin