Problem with metadata file

Hi there,

My metadata.tsv file is not recognized well by Qiime. I prepared metadata in excel first, then copy it into notepad, and run this command to check:
cat $WORKING/metadata.tsv

It did not showed me a well recognized table…i mean some information are present in wrong columns.

I would like to ask if you could suggest me a command or a text editor to make a great metadata file.

Thank you very much,

Best regards,

Toan

Hi @Toan!

Copying the contents from Excel into a text file won’t work. Try exporting the file from Excel as TSV (Tab-Separated Values, .tsv file extension). There’s resources online that’ll show you how to do this in Excel, e.g. this page.

Hi @jairideout,

Thank you very much for your reply!

I have tried what you suggested by saving the file as “Text (Tab delimited) (*.txt)”. But it is still wrong:

image

image

I am looking for your advices.

Best,

Toan

It looks like you’re creating a QIIME 1-style metadata file, where the header is a comment line (i.e. starts with #). As described in the metadata file format spec, if you’re using a QIIME 1-style file, the header must start with #SampleID. Note that in your file, you have an extra space in the name: #Sample ID.

You have a couple of options:

  • Rename the first cell to #SampleID (i.e. remove the space).

OR:

  • Remove the # character from the first cell (then you can name the cell whatever you want).

If that doesn’t work, please attach the TSV metadata file you’re using, and include the exact command and error message you’re receiving. Thanks!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.