Problem with feature-table group

I have successfully created a dendrogram showing sampleID at each tip, but for my research question I need to group samples by a specific metadata column (so that each tip will show host species). I tried running the following command:

qiime2 feature-table group --i-table v2-table-dada2.qza --p-axis feature --m-metadata-file Phylo_mapping.txt --m-metadata-column Species --p-mode mean-ceiling --o-grouped-table v2-table-by-species

but got an error message that I’m struggling to understand:

Plugin error from feature-table:

The following IDs are not present in the metadata: β€˜0000f717edf416e80ec2f2abf5c08397’, β€˜00166b25ae06a4317f7ba6725709519b’, β€˜001c1c130c067d84955fee6a906053c6’, β€˜00250e4a9d4f542d986024e1d3f39698’, β€˜002c96b09cc70b37f3d44b8c85ac1164’, β€˜003142de1b33ca977be39b3a9024e3d9’, β€˜00483c7e9674b5ca7ec221e4d5f8ee03’, β€˜00608757a9d5dc68767d3fa5044bf6c8’, β€˜0066246dec0549517f360eac54126d2d’, β€˜0070201d1f3de9573969cfe9bbbba444’, β€˜0073df206ab7ed634b96d54b66279564’, β€˜007cdf96c0dd557b5689ac0809e062f7’, β€˜007f6c79ea9761a287ada590288fe93c’,…Debug info has been saved to /tmp/qiime2-q2cli-err-y6fw1idc.log

I am using q2cli version 2018.11.0

Any advice would be appreciated!

I suppose you are doing it a little bit wrong

If you want to group samples, you should provide
--p-axis 'sample'
instead of
--p-axis feature


That worked, thank you!!