Problem with biom

Hello,

When I try to run a biom command (convert or summarize), the cursor goes to the next line and remains blinking without any feedback (error message). biom is able to run the help commands. Any pointers? I am trying to convert my exported feature table to a tsv using biom convert. I believe there is an issue with the biom file produced by qiime tools export and the inputs I put into the qiime pipeline prior to that.

comand:
biom convert -i file.biom -o table.tsv --to-tsv

Thank you!
Andrew

Hello Andrew,

Welcome to the forums! :qiime2:

This means the command is running :hourglass_flowing_sand: :stopwatch:

Just wait for it to finish or show an error. :person_in_lotus_position:

(Some commands can take a long time, depending on the size of your data. :person_shrugging: )

Hi Colin,

Thank you for your reply and your warm welcome!

I'm letting it run now. However, when I use top to see the list of processes running, I don't see any process running under my login. I thought maybe something is wrong with the installation, so I tried running biom convert on galaxy. It gave me this error: Execution of this dataset's job is paused because its input datasets are in an error state. I've attached the feature table .qza and the exported .biom from it.

feature-table.biom (73.7 KB)
feature-table.qza (121.3 KB)

1 Like

Hi @andrew_g,

Can you provide the entire export command you ran (i.e. qiime tools export... etc)? I'll try to recreate this on my end. Thanks!

Hi Liz,

Here is the command:

qiime tools export --input-path feature-table.qza --output-path exported-feature-table

Thank you!

1 Like

Hi @andrew_g,

Thanks! Okay so I checked provenance on your feature table and saw that 2022.8 was the version of QIIME 2 you used to generate that feature table, so I made sure to use the same environment as you to recreate this. So using QIIME 2 2022.8 I ran qiime tools export on your feature table, and then ran biom convert --to-tsv on the subsequent feature-table.biom file. This ran without issue, and completed for me in <1 sec.

I have a couple of thoughts on this:

  1. (Apologies if this is one obvious and you've already checked) Can you confirm that the TSV file wasn't successfully created and in the CWD as where you ran your command?
  2. I wonder if there is a competing version of biom on your machine that's causing problems when you run biom convert. We haven't made any changes to the version of biom we're using in QIIME 2, and neither of those commands have been updated recently, so it seems unlikely that the issue stems from either of those commands.

Can you run which biom and share the terminal output in your response? Thanks!

1 Like

Hi @lizgehret,

That is good to hear!

On your thoughts:

  1. (No worries! The obvious can be elusive :p) It is not in the CWD.

  2. I believe that there is another version. When I run which biom, I get this: /Users/lab/.local/bin/biom
    When I try to use biom with or without Qiime loaded, the same details mentioned in my first post on this topic persist.

1 Like

Hi @andrew_g,

Thanks for providing those details!

I suspect this is where the issue lies. I'd recommend deleting this version of biom and then trying to re-run biom convert... in your QIIME 2 environment - since biom is included in each QIIME 2 environment, you should then be using the correct version. But let us know if you're still running into the same problem!

Cheers :lizard:

1 Like

Hi @lizgehret,

Thank you for pointing me in the right direction! I am working with our systems administrator to get the correct setup.

Andrew

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.