problem while importing single-end demultiplexed with quality data in qiime2

Hello, I've been experiencing the following error: (1/1?) No such option: --imput-path (Possible options: --input-path, --output-path)
I have single-end demultiplexed with quality data and I'm trying to import them in qiime in order to create .qza file. The command that I used and gives me the above error is the following:
qiime tools import
--type 'SampleData[SequencesWithQuality]'
--imput-path reads
--input-format CasavaOneEightSingleLanePerSampleDirFmt
--output-path demux-single-end2.qza

I downloaded the file: "casava-18-single-end-demultiplexed.zip" and tried the additional command from: Importing data — QIIME 2 2023.9.2 documentation just to see how this is working and it worked. Additional command:
qiime tools import
--type 'SampleData[SequencesWithQuality]'
--input-path casava-18-single-end-demultiplexed
--input-format CasavaOneEightSingleLanePerSampleDirFmt
--output-path demux-single-end.qza

Since the problem in my command is about the input-path, I checked the files inside the casava-18-single-end-demultiplexed directory and realized that all the files ends with ...fastq.gz. The files in my directory "reads/" ends with ...fastq. Is this maybe the problem? How do I approach is?

Welcome to the forum!

There is no such option since there is a typo: imput should be input.

Good catch!
You can gzip you files:

cd path/to/reads
gzip ./*.fastq
2 Likes

I corrected my mistake but unfortunately casava isn't working for me. Instead, I tried the following command and it worked for me!

qiime tools import
--type 'SampleData[SequencesWithQuality]'
--input-path manifest.csv
--output-path single-end-demux.qza
--input-format SingleEndFastqManifestPhred33

Tip: You have to create this manifest.csv file first which contains the information about my reads.

1 Like