Problem viewing Emperor plot with qiime tools view command and


Today I have encountered a problem in viewing Emperor plots. I couldn't see them using the qiime tools view command as well as the (attached photo):

It's also weird because on Monday I could still see the Emperor plot. And I have no problem viewing the other visualizations using both ways. Hope you guys can help!

Hi @AllieNguyen, thanks for reporting this problem. If at all possible would you mind uploading this artifact into Dropbox or alternatively sharing it through the forum?

If that’s not possible, then could you let me know what you see in the JavaScript console of your web browser while viewing these plots? In FireFox I think you can go to: Tools > Web Developer > Web Console. Additionally, could you also try a different web browser? It seems rather suspicious that this worked before but it no longer works. I think a recent software update to your browser might be the culprit.

Hi @yoshiki,

I used Chrome to open and when using the command qiime tools view it opened the file in Firefox. Here are the files I tried to open: bray_curtis_emperor.qzv (766.4 KB)
weighted_unifrac_emperor.qzv (766.8 KB)

Regarding the update, I haven't updated my Chrome, for the Firefox I'm not sure because it's not my computer but an Uni computer node that I've got access to.

Thanks for sending the qzvs.

After looking at these plots, it seems like you have found a bug. Emperor cannot display a plot where there are only two samples. More specifically (in your case) since any resulting ordination with 2 samples would have at most 2 dimensions, the code is failing because it assumes all displayed matrices will have 3 dimensions.

I would be surprised if this worked before, maybe you had included more samples before?

Hi Yoshiki,

The plot I have are for 4 samples. It is indeed that I was working with more samples before. However, I thought the process would crash if an emperor plot could not be done?

@AllieNguyen four samples should display with no problem. Unfortunately what is crashing is not the QIIME command but the user interface that displays the data. I’ve opened an issue here to fix this or provide a meaningful error message.

As a side note: I would suggest that you reconsider using an ordination as a display for two samples, since it might not be the best representation.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.