Problem: Use of .fq file while importing

Hi,

I am working with 16S amplicon data obtained via outsourcing our 1 sample, and they provided us with two files A01_R1.fq and A01_R2.fq, where my sample id is A01.

Can I use these files in QIIME2???
Can somebody tell me, how to import such kind of data/file?

I am very new to this kind of analysis. Any kind of help will be appreciated.

Best Regards,

Rashmi

Hello!
So, for your sample AO1 you have forward (R1) and reverse (R2) reads. To import it to qiime2, you can rename the extension of the files to .fastq instead of .fq and then use "gzip" to zip the files (you will get .fastq.gz). Then search for qiime2 importing tutorial and import it as paired reads with manifest.

Best,

Hi @timanix,

Thanks for your response. I already tried that way to import, but it's not working.

In fact I tried another command by using manifest

qiime tools import --type 'SampleData[PairedEndSequencesWithQuality]' --input-path manifest.csv --input-format PairedEndFastqManifestPhred33 --output-path paired-end-demux.qza

But getting error: screenshot attached

and
This how manifest file looks like:

Please suggest, what I can do further???

Best Regards

Did you check the importing tutorial?

Here is an example of manifest file.

1 Like

Yes, I tried with this format too, but it is not working.

Is the error changed, or it was the same?

no, it's changed.

Hi @Rashmi_Ira,
It looks like QIIME is having a hard time finding your data. Can you confirm your data is in this file path?

3 Likes

Hi @cherman2,

Yes, my .fastq data (AJ01_R1.fq and AJ01_R2.fq) is present in the above-mentioned path.

Hi @Rashmi_Ira,

Can you please provide a screenshot that includes the full filepath confirming the location of AJ01_R1.fastq? Additionally, it may be helpful for us to take a look at the manifest file you've created to make sure there are no formatting issues. Thanks! :lizard:

3 Likes

Hi @Rashmi_Ira,
I noticed you might have a capitalization error in your file path. This screenshot shows that you have a directory named Metagenoics_OOty_AJ

But your manifest error says that its looking in a directory called Metagenoics_Ooty_AJ. The difference in capitalization here would cause qiime2 not to find your files. Can you confirm that the files are in the file path that contains "Metagenoics_OOty_AJ". If that's the case you will have to edit your manifest to contain the correct file path!

Hope that helps!

3 Likes

HI @lizgehret

Sorry for the late response.
Here is the path for AJ01_R1.fq and AJ01_R2.fq files:

/home/rashmi/Rashmi_IMPRINT_PhD_data/Metagenoics_OOty_AJ

Please find the manifest file:
manifest.csv (226 Bytes)

sample-id,absolute-filepath,direction
AJ01_R1.fq,/home/rashmi/Rashmi_IMPRINT_PhD_data/Metagenoics_Ooty_AJ/MBL_AJ/AJ01_R1.fq,forward
AJ01_R2.fq,/home/rashmi/Rashmi_IMPRINT_PhD_data/Metagenoics_Ooty_AJ/MBL_AJ/AJ01_R2.fq,reverse

Thanks and Regards,
Rashmi

Hi @cherman2

Thank you so much for your response.
Yes I checked that, there's some problem with the manifest file. I am trying to Capitalize both OO but unable to do that.. so I have generated another file, after changing the folder name from "Metagenoics_OOty_AJ" to "Metagenoics_Ooty_AJ"

sample-id,absolute-filepath,direction
AJ01_R1.fq,/home/rashmi/Rashmi_IMPRINT_PhD_data/Metagenoics_Ooty_AJ/MBL_AJ/AJ01_R1.fq,forward
AJ01_R2.fq,/home/rashmi/Rashmi_IMPRINT_PhD_data/Metagenoics_Ooty_AJ/MBL_AJ/AJ01_R2.fq,reverse

@lizgehret @cherman2 @timanix
Thank you all, it's working now. I have changed the folder name as well as the style of manifest file
manifest-manifest.tsv (217 Bytes)

and imported the data under

qiime tools import
--type 'SampleData[PairedEndSequencesWithQuality]'
--input-path manifest-manifest.tsv
--output-path paired-end-demux.qza
--input-format PairedEndFastqManifestPhred33V2

Thanks and Regards,
Rashmi Ira

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.