problem installing q2 studio

Hello,

I have recently installed qiime2-2019.7 and I wanted to try q2studio.
I am following the tutorial available online, thus i activate my qiime2 environment and then i download q2 zip file, but when i perform the pip install i get the following error:

 (qiime2-2019.7) michael:~/Desktop/q2studio-2019.7.0$ pip install .
Processing /home/michael/Desktop/q2studio-2019.7.0
Requirement already satisfied: click in /home/michael/anaconda3/lib/python3.7/site-packages (from q2studio==2019.7.0) (6.7)
Requirement already satisfied: flask in /home/michael/anaconda3/lib/python3.7/site-packages (from q2studio==2019.7.0) (1.0.2)
Requirement already satisfied: gevent in /home/michael/anaconda3/lib/python3.7/site-packages (from q2studio==2019.7.0) (1.3.6)
Collecting qiime2==2019.7.* (from q2studio==2019.7.0)
  Could not find a version that satisfies the requirement qiime2==2019.7.* (from q2studio==2019.7.0) (from versions: )
No matching distribution found for qiime2==2019.7.* (from q2studio==2019.7.0)
You are using pip version 10.0.1, however version 19.2.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

can someone help me to deal with that? i don’t really get the error.
Thanks

Hey @michele_quail,

Could you run these two commands in that environment:

conda list

and

which pip

I suspect either you are missing the framework somehow (seems unlikely, but worth checking), or the pip which is currently being used is from outside the environment (this happens to me often enough, and deactivating+reactivating the env is usually enough to fix it).