Problem importing paired end, demultiplexed, shotgun metagenomic data

Hi all,

I'm currently trying to import a set of paired-end demultiplexed reads using the manifest format, and for some reason it's not working!

Here's my code:

qiime tools import \
  --type 'SampleData[SequencesWithQuality]' \
  --input-path post_qiita_hackflex_manifest.txt \
  --output-path imported_sequences_qiita.qza \
  --input-format SingleLanePerSamplePairedEndFastqDirFmt

And I get this error:

**There was a problem importing post_qiita_hackflex_manifest.txt:**

**post_qiita_hackflex_manifest.txt is not a directory.**

I'm confused because I know the file exists, and I'm doing everything in the correct directory. My manifest file is attached below.

Thanks for your help!

Sam

post_qiita_hackflex_manifest.txt (10.3 KB)

Hello!

The reason is that you should use "SingleEndFastqManifestPhred33V2" instead of "SingleLanePerSamplePairedEndFastqDirFmt" when importing with a manifest file.
Please, double check that you want to import it as single end reads, cause in your ḿanifest file there are both F and R reads. For paired reads, use "PairedEndFastqManifestPhred64V2".

1 Like

Thanks for the reply! I had tried PairedEndFastqManifestPhred64V2 earlier, and got this error:

**An unexpected error has occurred:**

**No transformation from <class 'q2_types.per_sample_sequences._format.PairedEndFastqManifestPhred64V2'> to <class 'q2_types.per_sample_sequences._format.SingleLanePerSampleSingleEndFastqDirFmt'>**

**See above for debug info.**

That's why I tried using SingleLanePerSamplePairedEndFastqDirFmt.

Any ideas?

I use
--input-format PairedEndFastqManifestPhred33V2
for importing paired end reads

2 Likes

Thanks for the suggestion, but I get a similar error to when I try the Phred64V2 offset.

Traceback (most recent call last):
  File "/programs/miniconda3/envs/qiime2-2021.4/lib/python3.8/site-packages/q2cli/builtin/tools.py", line 157, in import_data
    artifact = qiime2.sdk.Artifact.import_data(type, input_path,
  File "/programs/miniconda3/envs/qiime2-2021.4/lib/python3.8/site-packages/qiime2/sdk/result.py", line 240, in import_data
    return cls._from_view(type_, view, view_type, provenance_capture,
  File "/programs/miniconda3/envs/qiime2-2021.4/lib/python3.8/site-packages/qiime2/sdk/result.py", line 265, in _from_view
    transformation = from_type.make_transformation(to_type,
  File "/programs/miniconda3/envs/qiime2-2021.4/lib/python3.8/site-packages/qiime2/core/transform.py", line 58, in make_transformation
    raise Exception("No transformation from %r to %r" %
Exception: No transformation from <class 'q2_types.per_sample_sequences._format.PairedEndFastqManifestPhred33V2'> to <class 'q2_types.per_sample_sequences._format.SingleLanePerSampleSingleEndFastqDirFmt'>

An unexpected error has occurred:

  No transformation from <class 'q2_types.per_sample_sequences._format.PairedEndFastqManifestPhred33V2'> to <class 'q2_types.per_sample_sequences._format.SingleLanePerSampleSingleEndFastqDirFmt'>

See above for debug info.

Hello again!
In addition to suggested above variant by @kindergarten, could you also try to change "type"?

--type 'SampleData[PairedEndSequencesWithQuality]'

This worked! Thanks to both you and @kindergarten!