problem importing multiplexed paired-end FASTQ with dual-index barcodes in sequence

I'm having some trouble importing my Miseq paired-end reads.
My reads are structured like this:
illumina adapter - Ns - barcode - AMPLICON
both forward and reverse reads have barcodes and they are in sequence.
I have generated a metadata.tsv file with three columns for my dual-index sequences like this:

sample_name barcode1 barcode2
smplB1 aacaagcc acaaccga
smplH1c ggaatgag acaaccga

I have a dir with the following files:
forward.fastq.gz metadata.tsv reverse.fastq.gz

The command I run is:
qiime tools import
--type MultiplexedPairedEndBarcodeInSequence
--input-path muxed-pe-barcode-in-seq
--output-path multiplexed-seqs.qza

The error I get is:
There was a problem importing muxed-pe-barcode-in-seq:

Unrecognized file (muxed-pe-barcode-in-seq/metadata.tsv) for MultiplexedPairedEndBarcodeInSequenceDirFmt.

I think that the issue regards the metadata table but I was not able to retrieve some sample table to copy it. (QIIME2 ver qiime2-2023.5).
Thank you all!

Hello @alexcussigh0, that error is saying the import command wasn't expecting a metadata file and doesn't know what to do with it.

The importing tutorial here explains how to set up the directory format to import an artifact of that type. It has forward reads and reverse reads but no metadata.

The docs do talk about a metadata file, but that should not be in the directory you import. You will need that later when you try to run actions with your artifact. The wording of the docs is confusing though and makes it sound like the metadata should be in the directory you import. I will make note of that.

@Oddant1 thank you so much, it worked! I must say that wording of that paragraph it's quite misleading ahah
thx again

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.