Problem importin data with manifest format for pair end sequences

Hello I am having an issue when important the sequences to qiime. I demultiplex my sequences with the Stacks pipeline and then I runned trimmomatic over them to cut the adaptors and primer sequences. Moroever, I quality filtered them in this step. Now I would like to use Qiime2 for the following steps however I am having problems importing my data:
the code I am running is the following:

qiime tools import
--type 'SampleData[SequencesWithQuality]'
--input-path manifest_file_upper_elevations.tsv
--output-path clean-demux-ITS-2.qza
--input-format PairedEndFastqManifestPhred33V2

I got the following error:

Traceback (most recent call last):
File "/home/guillermo/anaconda3/envs/qiime2-2022.8/lib/python3.8/site-packages/q2cli/builtin/", line 157, in import_data
artifact = qiime2.sdk.Artifact.import_data(type, input_path,
File "/home/guillermo/anaconda3/envs/qiime2-2022.8/lib/python3.8/site-packages/qiime2/sdk/", line 299, in import_data
return cls.from_view(type, view, view_type, provenance_capture,
File "/home/guillermo/anaconda3/envs/qiime2-2022.8/lib/python3.8/site-packages/qiime2/sdk/", line 325, in _from_view
transformation = from_type.make_transformation(to_type,
File "/home/guillermo/anaconda3/envs/qiime2-2022.8/lib/python3.8/site-packages/qiime2/core/", line 58, in make_transformation
raise Exception("No transformation from %r to %r" %
Exception: No transformation from <class 'q2_types.per_sample_sequences._format.PairedEndFastqManifestPhred33V2'> to <class 'q2_types.per_sample_sequences._format.SingleLanePerSampleSingleEndFastqDirFmt'>

An unexpected error has occurred:
No transformation from <class 'q2_types.per_sample_sequences._format.PairedEndFastqManifestPhred33V2'> to <class 'q2_types.per_sample_sequences._format.SingleLanePerSampleSingleEndFastqDirFmt'>

My sequences look like this:

and my manifest file is:
manifest_file_upper_elevations.tsv (4.0 KB)

My files are name in the following way (20 pairs):

and so on

I have tried several options and check the tutorials but I did not solve my problem. I would appreciate if I could receive some help.

Thanks a lot in advance! :slight_smile:


you should use a different semantic type for importing paired end, namely SampleData[PairedEndSequencesWithQuality]


1 Like

@crusher083 Thanks a lot for your quick reply. I changed and It seemed to have worked, however, I am having another issue. I get this error and I can't spot what wrong with my manifest file

There was a problem importing manifest_file_upper_elevations.tsv:

manifest_file_upper_elevations.tsv is not a(n) PairedEndFastqManifestPhred33V2 file:

'forward-absolute-filepath' is not a column in the metadata. Available columns: 'forward-absoluteā€filepath', 'reverse-absoluteā€filepath'

Hi @Guillermo_U,

This error is letting you know that the required column headers are missing:

The manifest file should appear as outlined here.

1 Like

Thank you but I exactly have those colunms in my file. You can check it further up XD

Ahh right! Sorry about that! :man_facepalming:

The one issue I see, is that there is no / in front of home. That is:


should be :


@SoilRotifer Thanks I have changed that and still nothing . I get the same error

Thanks @SoilRotifer and @crusher083 for helping me out! I spotted the mistake and now it is working. Now I will try to merged the sequences.

Thanks a lot again

1 Like

@Guillermo_U, Can you let us know what the issue was, so other forum users can benefit? :slight_smile:

@SoilRotifer So at first it was the data type as your colleague point out and then the issue of the filepath that you pointed out. After your second message I changed the filepaths but I missed one of them, so it was a stupid mistake from my side :grinning:. Nothing too useful for the community


No worries @Guillermo_U! Great detective work! :male_detective:


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.