Possible Analysis Pipeline for Ion Torrent 16S Metagenomics Kit Data in QIIME2?

You did!

That’s correct.

Looks like you found the correct file. For future reference, you can find these and other files linked from here (scroll down): https://docs.qiime2.org/2020.2/data-resources/

rep_set (these are the unaligned sequences)

Good question… I am not sure, and not totally sure if it matters. I’d say try XX_otus.tree and you will probably run into an error pretty quickly if that’s the wrong one.

4 Likes

I use XX_otus.tree and I import it according to the importing instruction, but as anticipated by Nicholas… in the core matrics step I have this error

Plugin error from diversity:

All non-root nodes in tree must have a branch length.

Debug info has been saved to /var/folders/nk/qyjfz4t11vn5vnx07bkphqrw0000gn/T/qiime2-q2cli-err-u3wm8n8f.log.

Now I’m trying to solve it as suggest by Nicholas…
I hope to do it, if you solve before me please let me know :), a hand is always welcome!

Thanks,
Rubina

1 Like

Good morning to all!
In the past days I have tried to solve the problem that I described previously without results has anyone managed and can you give me a hand?
I can not go on …

thank you very much

Rubina

Hi @rparadiso,
Since this is not strictly relevant to this topic (it is an issue with that specific reference tree and, e.g., you could use a different reference tree), do you want to open up a separate topic to solve your q2-fragment-insertion issue? If that solution is relevant to the current discussion, we can link back to that here.
Thanks!

1 Like

Hi Rubina,

@Lauren and I have been trying to troubleshoot this too, but with no luck so far. We got the same error as you when we repeated what you did, and also when we tried the same code but after importing the XX_otus_unannotated.tree.

We aren't sure how to use Python to fix the branch length issue as shown in the post that @Nicholas_Bokulich linked to - our computing cluster does have Python built in but we haven't been able to figure out how to actually use it yet :sweat_smile:.

We look forward to your thread on this and will plan to chime in there!

Best,
Carli :qiime2:

1 Like

ok Nicholas

thank you :slight_smile:

Hi everyone,
@rparadiso was able to solve the greengenes branch length issue in a separate topic — see here for a few different solutions:

@cjone228 that topic lists some other options — opening and manually modifying the file, or running a python script in the bash shell (command line), so there are a few options to suit whatever you feel most comfortable working with.

Please post to that topic if you have any follow-up questions or run into any issues with fixing your tree(s).

1 Like

Hi all,

@Lauren and I have successfully completed the steps we discussed above on our mock community data thanks to the python script to fix the tree! :partying_face: @rparadiso @Nicholas_Bokulich

Just for fun, we are going to try doing the same steps again using our mock community but this time using SILVA as our reference database! :evergreen_tree: :dna:

Best,
Carli :qiime2:

5 Likes

Whoa, this is great news! :champagne:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.